Bug 1202631 - superfluously creates initramfs twice on netinstalls
Summary: superfluously creates initramfs twice on netinstalls
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 05:03 UTC by Chris Murphy
Modified: 2015-04-13 18:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-13 18:53:41 UTC
Type: Bug


Attachments (Terms of Use)
journal (806.29 KB, text/plain)
2015-03-17 05:04 UTC, Chris Murphy
no flags Details
anaconda.log (35.42 KB, text/plain)
2015-03-17 05:04 UTC, Chris Murphy
no flags Details
storage.log (227.91 KB, text/plain)
2015-03-17 05:04 UTC, Chris Murphy
no flags Details
program.log (57.15 KB, text/plain)
2015-03-17 05:04 UTC, Chris Murphy
no flags Details
packaging.log (3.23 KB, text/plain)
2015-03-17 05:05 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2015-03-17 05:03:24 UTC
Description of problem: The primary (hostonly) initramfs is generated twice on netinstalls.


Version-Release number of selected component (if applicable):
anaconda 22.20.2-1

How reproducible:
Always on netinstalls.

Steps to Reproduce:
1. Do a netinstall.


Actual results:

journal records dracut running twice for the same initramfs

Mar 17 04:44:18 localhost dracut[2508]: Executing: /sbin/dracut -f /boot/initramfs-4.0.0-0.rc3.git0.1.fc22.x86_64.img 4.0.0-0.rc3.git0.1.fc22.x86_64


Mar 17 04:46:07 localhost.localdomain dracut[24726]: Executing: /sbin/dracut -f /boot/initramfs-4.0.0-0.rc3.git0.1.fc22.x86_64.img 4.0.0-0.rc3.git0.1.fc22.x86_64


Expected results:

Seems like once is enough.

Additional info:

Because the kernel RPM package executes new-kernel-pkg it seems like anaconda doesn't need to do it also. This is what instigates the second execution:

22:45:57,566 INFO program: Running... new-kernel-pkg --mkinitrd --dracut --depmod --update 4.0.0-0.rc3.git0.1.fc22.x86_64

Comment 1 Chris Murphy 2015-03-17 05:04:01 UTC
Created attachment 1002605 [details]
journal

Comment 2 Chris Murphy 2015-03-17 05:04:12 UTC
Created attachment 1002606 [details]
anaconda.log

Comment 3 Chris Murphy 2015-03-17 05:04:24 UTC
Created attachment 1002607 [details]
storage.log

Comment 4 Chris Murphy 2015-03-17 05:04:43 UTC
Created attachment 1002608 [details]
program.log

Comment 5 Chris Murphy 2015-03-17 05:05:43 UTC
Created attachment 1002610 [details]
packaging.log

Comment 6 Martin Kolman 2015-03-17 10:15:05 UTC
The second initrd regeneration is done after packages are installed and after Anaconda generated configuration files are installed. The regeneration is needed so that the Anaconda generated configuration files are taken into account when Dracut creates the initrd - users might have specified additional keymaps and want to use them to unlock LUKS, etc.

On the other hand, the first initrd creation triggered by the kernel package is indeed superfluous - it would make sense to skip it if we will create a new initrd once package installation is done anyway.

Comment 7 David Shea 2015-04-13 18:53:41 UTC
The new-kernel-pkg --update call needs an initrd to start from, so this isn't even superfluous.


Note You need to log in before you can comment on or make changes to this bug.