Bug 1202633 - [RFE] Allow to specify which (sub-) tests to run in rpmgrill
Summary: [RFE] Allow to specify which (sub-) tests to run in rpmgrill
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: rpmgrill
Classification: Community
Component: Tests
Version: 0.23
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 0.30
Assignee: Matus Marhefka
QA Contact:
URL:
Whiteboard:
: 1236637 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 05:16 UTC by Roman Joost
Modified: 2017-01-16 20:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: 8
Clone Of:
Environment:
Last Closed: 2017-01-16 19:50:23 UTC


Attachments (Terms of Use)

Description Roman Joost 2015-03-17 05:16:25 UTC
It is important to provide a way to select which tests should be run against a build to be analysed. This can come in handy if some of the tests in the suite are not applicable for the build.

Comment 1 Sunil Thaha 2015-04-24 03:17:34 UTC
I have my initial analysis of implementing this feature documented[1]. 

tldr: conclusion
----------------
I think this feature is an overkill because every test will now need to be a plugin as well.


[1]  https://github.com/default-to-open/rpmgrill/wiki/Feature:-run-only-selected-tests

Comment 2 Sunil Thaha 2015-04-24 03:18:48 UTC
Miroslav, are you only interested in suppressing some of the test results?

Comment 3 Miroslav Vadkerti 2015-06-30 07:49:05 UTC
Hi Sunil. We have taken another approach that does not need so much code changes. Looking at testing times we concluded that running the tests themselves does not  take too long, compared to extracting the packages sources. So we simply suppress the reporting of the tests in the gripe function via a blacklist file. Matus Marhefka has created a simple patch and will be posting a pull request on the github soon ...

Comment 4 Matus Marhefka 2015-06-30 11:53:04 UTC
pull request: https://github.com/default-to-open/rpmgrill/pull/2

Comment 5 Matus Marhefka 2015-06-30 11:57:32 UTC
*** Bug 1236637 has been marked as a duplicate of this bug. ***

Comment 6 Meiying Li 2015-08-27 03:04:44 UTC
Have added an option for rpmgrill-0.28-2.fc22.noarch:
       --blacklist-config=FILE
           Blacklisted tests will not be reported by rpmgrill. Blacklist configuration FILE is in YAML format:

           blacklist:
             Plugin1: test1, test2
             Plugin2: test3
             ...

           and tells rpmgrill that it should not report fails for specified tests within certain plugins.

Comment 7 Fedora Update System 2017-01-04 05:02:12 UTC
rpmgrill-0.29-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-908e8c0e6f

Comment 8 Fedora Update System 2017-01-04 05:47:58 UTC
rpmgrill-0.29-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-055deefcec

Comment 9 Fedora Update System 2017-01-04 22:22:05 UTC
rpmgrill-0.29-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-055deefcec

Comment 10 Fedora Update System 2017-01-04 23:29:08 UTC
rpmgrill-0.29-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-908e8c0e6f

Comment 11 Fedora Update System 2017-01-06 04:33:55 UTC
rpmgrill-0.30-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-908e8c0e6f

Comment 12 Fedora Update System 2017-01-06 04:35:25 UTC
rpmgrill-0.30-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-055deefcec

Comment 13 Fedora Update System 2017-01-06 23:20:16 UTC
rpmgrill-0.30-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-908e8c0e6f

Comment 14 Fedora Update System 2017-01-07 01:18:38 UTC
rpmgrill-0.30-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-055deefcec

Comment 15 Fedora Update System 2017-01-16 19:50:23 UTC
rpmgrill-0.30-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-01-16 20:49:23 UTC
rpmgrill-0.30-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.