Bug 1202661 - Aggregation of disks usage is running slow
Summary: Aggregation of disks usage is running slow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Shirly Radco
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks: 1210988
TreeView+ depends on / blocked
 
Reported: 2015-03-17 07:25 UTC by Shirly Radco
Modified: 2016-03-09 21:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1210988 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:23:10 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0404 normal SHIPPED_LIVE rhevm-dwh bug fix and enhancement update 2016-03-10 01:29:45 UTC
oVirt gerrit 38812 None None None Never
oVirt gerrit 39450 None None None Never

Description Shirly Radco 2015-03-17 07:25:40 UTC
Description of problem:
It was reported that the aggregation of vm_disks_usage_samples_history to hourly
was running slow.  

Version-Release number of selected component (if applicable):
3.5

How reproducible:


Steps to Reproduce:
1. Install and setup engine and dwh 3.5 environment.
2. Replace the ovirt_engine_history database with the one that sradco will supply to this bug.
3. Check performance of hourly aggregation

Actual results:
Very high cpu usage when performing hourly aggregations.

Expected results:
Should normal cpu usage and not have high impact on cpu usage. 

Additional info:
Should test that aggregation is same as before.

Perform test before and after the upgrade on the same data.

Comment 3 errata-xmlrpc 2016-03-09 21:23:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0404.html


Note You need to log in before you can comment on or make changes to this bug.