Bug 1202735 - qtwebkit: undefined symbol: g_type_class_adjust_private_offset
Summary: qtwebkit: undefined symbol: g_type_class_adjust_private_offset
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qtwebkit
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 10:58 UTC by John Pilkington
Modified: 2015-04-15 16:55 UTC (History)
8 users (show)

Fixed In Version: qtwebkit-2.3.4-6.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-09 16:57:06 UTC


Attachments (Terms of Use)

Description John Pilkington 2015-03-17 10:58:16 UTC
Description of problem: after upgrade from 2.3.3-3, mythbackend fails to start, with report:

mythbackend: symbol lookup error: /lib64/libQtWebKit.so.4: undefined
symbol: g_type_class_adjust_private_offset


Version-Release number of selected component (if applicable): 2.3.4-1


How reproducible: not tried


Steps to Reproduce:
1.
2.
3.

Actual results: Works as normal with 2.3.3-3


Expected results:


Additional info: reported here:
http://www.gossamer-threads.com/lists/mythtv/dev/584190#584190

Comment 1 Rex Dieter 2015-03-17 12:51:15 UTC
Some extra info please, can you post the output of these 2 commands?  Thanks.


cat /etc/redhat.release

rpm -q qtwebkit glib2

Comment 2 John Pilkington 2015-03-17 13:02:42 UTC
cat /etc/redhat.release
cat: /etc/redhat.release: No such file or directory

but

cat /etc/redhat-release
Scientific Linux release 7.0 (Nitrogen)

rpm -q qtwebkit glib2
qtwebkit-2.3.3-3.el7.x86_64  (after reversion)
glib2-2.36.3-5.el7.x86_64

Comment 3 Rex Dieter 2015-03-17 15:04:27 UTC
Looks like you need a glib2 update, qtwebkit was built against el 7.1's glib2-2.40.0-4.el7

Comment 4 John Pilkington 2015-03-17 16:45:20 UTC
OK, thanks, Rex.  I have SL7x repos active and that's in SL7rolling (pre-release).
I have it and qtwebkit/qtwebkit-devel from epel-testing installed now, and have seen no problems; but for other packages I'll probably stay with 7x...

Comment 5 Rex Dieter 2015-03-17 16:47:18 UTC
OK, I'll assume that's the problem then.  epel generally only supports the latest el release (7.1 in this case).

Feel free to reopen if you have more information and/or can reproduce against rhel 7.1 updates.

Comment 6 John Pilkington 2015-03-18 10:10:15 UTC
I feel there's something wrong here, though.  The package installed with no hint of trouble, yet caused problems in use.  Isn't there a case for a declared dependency?

Comment 7 Rex Dieter 2015-03-18 11:13:35 UTC
Possibly a case for adding a versioned dependency to enforce that yes.

But like I said, EPEL supports only latest RHEL releases, you're bound to run into trouble sooner or later trying to install epel pkgs on older releases.  So, best to just not do it... and implementing packaging workarounds may be counterproductive.

Comment 8 John Pilkington 2015-03-18 11:41:40 UTC
Yes, I had doubts about trying to install the newer glib2 but I thought it would be worthwhile to help confirm the cause of the problem.  At present it seems ok.  

Thanks again for your help and advice.

Comment 9 Fedora Update System 2015-03-20 15:14:49 UTC
qtwebkit-2.3.4-4.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1249/qtwebkit-2.3.4-4.el7

Comment 10 Orion Poplawski 2015-03-24 20:01:47 UTC
FWIW - the proper fix for situations like this would be for glib2 to implement symbol versioning.  Then the necessary requires/provides would be handled automatically.

Comment 11 Rex Dieter 2015-03-28 22:29:29 UTC
Marking ON_QA, recent builds add a versioned glib2 runtime dependency

Comment 12 Fedora Update System 2015-04-09 16:57:06 UTC
qtwebkit-2.3.4-6.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Andreas Nautsch 2015-04-12 18:47:02 UTC
error still persists. Error occurs on starting texmaker (which worked until Friday).

texmaker: symbol lookup error: /lib64/libQt5WebKit.so.5: undefined symbol: g_type_class_adjust_private_offset

info:
sudo rpm -q qtwebkit glib2
qtwebkit-2.3.4-6.el7.i686
glib2-2.36.3-5.el7.x86_64
glib2-2.36.3-5.el7.i686

sudo yum update glib*
No packages marked for update

yum --enablerepo epel-testing info glib2.x86_64
Name        : glib2
Arch        : x86_64
Version     : 2.36.3

uname -a
Linux localhost.localdomain 3.10.0-229.1.2.el7.x86_64 #1 SMP Thu Mar 26 09:10:25 CDT 2015 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/redhat-release
Scientific Linux release 7.0 (Nitrogen)

Comment 14 Rex Dieter 2015-04-12 21:43:43 UTC
You need glib2-2.40+ from rhel-7.1 per comment #3

That said, your rpm -q qtwebkit output only includes qtwebkit.i686, but the error you referenced was for
/lib64/libQt5WebKit.so.5
(a 64bit library).

what does this say?

rpm -q -f /lib64/libQt5WebKit.so.5

Comment 15 Andreas Nautsch 2015-04-13 05:02:49 UTC
rpm -q -f /lib64/libQt5WebKit.so.5
qt5-qtwebkit-5.4.1-4.el7.x86_64

but good point. I have 32-bit QT4 and 64-bit QT5 installed. QT4 for Skype and QT5 for texmaker; Skype still works. Until the update both were working.

rpm -q qt5-qtwebkit qt5-qtwebkit-devel
qt5-qtwebkit-5.4.1-4.el7.x86_64
qt5-qtwebkit-devel-5.4.1-4.el7.x86_64

Comment 16 Andreas Nautsch 2015-04-15 16:55:49 UTC
glib2 was updated yesterday/day before to 2.40; works now on SL7, sorry for the 2-day push.


Note You need to log in before you can comment on or make changes to this bug.