Bug 1202740 - Found the problem i also got org.hibernate.HibernateException: Wrong column type ... Found: bit, expected: boolean
Summary: Found the problem i also got org.hibernate.HibernateException: Wrong column t...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate
Version: 6.4.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: ---
Assignee: Gail Badner
QA Contact: Martin Simka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 11:02 UTC by Karel Piwko
Modified: 2015-06-22 18:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-22 18:14:03 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker AGPUSH-1314 0 Blocker Closed UPS 1.0.3 is not deploying on EAP 6.3 and MySQL 2015-06-22 18:26:09 UTC

Description Karel Piwko 2015-03-17 11:02:35 UTC
Description of problem:

Backport of fix delivered in HHH-6935. We are hit by this issue as we switched hbm2ddl.auto from create-drop to validate.

Found the problem i also got org.hibernate.HibernateException: Wrong column type ... Found: bit, expected: boolean

on BooleanType in hibernate 4 they changed the Ctor to

public BooleanType() {
this( org.hibernate.type.descriptor.sql.BooleanTypeDescriptor.INSTANCE, BooleanTypeDescriptor.INSTANCE );
}
instead of old versions

public BooleanType() {
this( BitTypeDescriptor.INSTANCE, BooleanTypeDescriptor.INSTANCE );
}

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. Deploy UPS with hbm2dll.auto = validate (default since 1.0.3 with migration)


Actual results:

Fails.

Expected results:

Passes.

Additional info:

This blocks running Unified Push Server 1.0.3 that supports migration from 1.0.2. We have a workaround though.

https://issues.jboss.org/browse/AGPUSH-1314
https://hibernate.atlassian.net/browse/HHH-6935

Comment 1 Gail Badner 2015-06-22 18:14:03 UTC
A fix for this issue does not appear to be required for EAP. The associated jira has been fixed without any Hibernate change required: https://issues.jboss.org/browse/MP-636 .


Note You need to log in before you can comment on or make changes to this bug.