Bug 1202745 - glusterd crashed on one of the node
Summary: glusterd crashed on one of the node
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard: glusterd
Depends On: 1202237 1235524 1236986
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 11:17 UTC by Atin Mukherjee
Modified: 2015-06-30 06:29 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1202237
Environment:
Last Closed: 2015-05-14 17:29:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-03-17 11:26:39 UTC
REVIEW: http://review.gluster.org/9908 (glusterd: Do not use global opinfo in syncop) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2015-03-24 06:22:50 UTC
COMMIT: http://review.gluster.org/9908 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 0940364b453fc37cb3e1844a743cf30c8ab2afc6
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Tue Mar 17 16:47:22 2015 +0530

    glusterd: Do not use global opinfo in syncop
    
    Global opinfo should not be referred by syncop framework as it uses local
    txn_opinfo for every transaction. There is one place in the codebase where the
    global opinfo is set with the local txn_opinfo which can lead to an incorrect
    opinfo for an on-going op-sm transaction which refers to the same global opinfo.
    
    Change-Id: Ida63a8871b8d03fe646146eddfd3f2473f1b1d7c
    BUG: 1202745
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/9908
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:29:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:38:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:46:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.