Bug 1202831 - mkfs.gfs2: Allow longer cluster names
Summary: mkfs.gfs2: Allow longer cluster names
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gfs2-utils
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Paul Evans
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 14:08 UTC by Robert Peterson
Modified: 2015-11-19 03:54 UTC (History)
4 users (show)

Fixed In Version: gfs2-utils-3.1.8-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 03:54:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch posted upsream (3.72 KB, patch)
2015-04-23 15:45 UTC, Paul Evans
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2178 0 normal SHIPPED_LIVE gfs2-utils bug fix and enhancement update 2015-11-19 07:52:21 UTC

Description Robert Peterson 2015-03-17 14:08:05 UTC
Description of problem:
Today, mkfs.gfs2 enforces a limit of 16 bytes for cluster name
(and 16 bytes for file system name) in the superblock, even
though there's room for 64 bytes (total) for sb_locktable.
The trouble is, pacemaker / corosync allow much longer cluster
names (not really limited). The dlm_controld seems to have a
64-byte limit*. Customers have complained that they create a
cluster, get it all running, then when they try to make the GFS2
file systems, mkfs.gfs2 rejects the cluster name for being too
long. However, renaming the cluster is not very easy to do.
I'd like to see us double the limit from 16:16 to 32:31 (need
to leave room for the colon).

Version-Release number of selected component (if applicable):
RHEL7.X

How reproducible:
Always

Steps to Reproduce:
# mkfs.gfs2 -O -p lock_dlm -j4 -t "financial_cluster:intec34p" /dev/mpathc/intec34p

Actual results:
locktable error: cluster name too long

Expected results:
No error

Additional info:
*
libdlm/libdlm.h:#define DLM_LOCKSPACE_LEN       64

Comment 2 Paul Evans 2015-04-23 15:45:25 UTC
Created attachment 1018051 [details]
Patch posted upsream

This patch increases the allowed cluster name to 32 bytes along
with increasing the allowed the file system name to 30 bytes.

Comment 5 Justin Payne 2015-08-11 15:36:34 UTC
Verified in gfs2-utils-3.1.8-4:

[root@host-050 ~]# rpm -q gfs2-utils
gfs2-utils-3.1.8-4.el7.x86_64
[root@host-050 ~]# mkfs.gfs2 -O -p lock_dlm -j4 -t "financial_cluster:intec34p" /dev/sda1
This will destroy any data on /dev/sda1
Device:                    /dev/sda1
Block size:                4096
Device size:               200.00 GB (52428544 blocks)
Filesystem size:           200.00 GB (52428541 blocks)
Journals:                  4
Resource groups:           802
Locking protocol:          "lock_dlm"
Lock table:                "financial_cluster:intec34p"
UUID:                      be01bc30-ede8-762b-a06d-50a1e180e9b6

Comment 7 errata-xmlrpc 2015-11-19 03:54:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2178.html


Note You need to log in before you can comment on or make changes to this bug.