Bug 1202876 - grubby: test fails on ppc64
Summary: grubby: test fails on ppc64
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grubby
Version: 23
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-03-17 15:31 UTC by Jakub Čajka
Modified: 2016-08-11 14:48 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-08-11 14:48:24 UTC


Attachments (Terms of Use)
Patch (1.54 KB, patch)
2015-03-17 15:31 UTC, Jakub Čajka
no flags Details | Diff

Description Jakub Čajka 2015-03-17 15:31:25 UTC
Created attachment 1002842 [details]
Patch

Test fails on ppc64 causing FTBFS. Seems as same issue as on aarch64. Failing test seems as intel specific only. I have prepared patch that skips failing test on not intel archs. As consequence tests could be enabled on arm/aarch64.

Failed build:
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=290470

Successful scratch builds with patch and enabled tests:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2422468
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2924017
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1759727

Could you please look in to it. This issue blocks ppc-f22-alpha.

Thanks,
Jakub

Comment 1 Jan Kurik 2015-07-15 14:23:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23

Comment 2 Rafael Fonseca 2015-08-13 15:11:44 UTC
Patch has been applied on git (commit 75676da). Can we close this bug?

Comment 3 Rafael Fonseca 2016-08-11 14:48:24 UTC
grubby >= 8.39-1 builds successfully in ppc64 and aarch64. Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.