Bug 1202907 - sat 6 no longer offering a suggested IP address after upgrade
Summary: sat 6 no longer offering a suggested IP address after upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule
Version: 6.0.8
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 16:44 UTC by Brett Thurber
Modified: 2019-06-13 21:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:19:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/foreman-proxy/proxy.log (2.24 KB, text/plain)
2015-03-17 16:44 UTC, Brett Thurber
no flags Details
foreman-debug (910.80 KB, application/x-xz)
2015-08-08 05:10 UTC, Brett Thurber
no flags Details
IP offered by sat6 (38.64 KB, image/png)
2015-10-06 10:41 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 8151 0 None None None Never
Red Hat Product Errata RHBA-2015:1911 0 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Brett Thurber 2015-03-17 16:44:35 UTC
Created attachment 1002875 [details]
/var/log/foreman-proxy/proxy.log

Description of problem:
After upgrading Sat 6 from 6.0.6 to 6.0.8, DHCP was no longer offering IP addrsses on local configured capsule.

Version-Release number of selected component (if applicable):
6.0.8

How reproducible:
Every time

Steps to Reproduce:
1. Upgrade Sat 6 OS from RHEL 7.0 to 7.1
2. Upgrade Sat 6 from 6.0.6 to 6.0.8 
3. Attempt to create a new host and it no longer is offered an IP address; attempts to suggest new fail.

Actual results:
No IP address offered.

Expected results:
IP address offered.

Additional info:
Output of /var/log/foreman-proxy/proxy.log attached.  
Confirmed resolution is:  chmod o+x /etc/dhcp

Comment 1 RHEL Program Management 2015-03-17 16:53:14 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ohad Levy 2015-05-13 11:14:30 UTC
the actual error in the logs say:

`Unable to find the DHCP configuration or lease files`

did you change your dhcp configuration (or updated packages etc) at the same time as upgrading satellite?

Comment 4 Brett Thurber 2015-05-13 14:20:13 UTC
(In reply to Ohad Levy from comment #3)
> the actual error in the logs say:
> 
> `Unable to find the DHCP configuration or lease files`
> 
> did you change your dhcp configuration (or updated packages etc) at the same
> time as upgrading satellite?

No changes made to existing configuration.

Comment 5 Ohad Levy 2015-05-31 14:05:28 UTC
please paste complete configuration files etc, this seems like a misconfigured system.

Comment 9 Brett Thurber 2015-08-08 05:10:25 UTC
Created attachment 1060526 [details]
foreman-debug

Comment 10 Kedar Bidarkar 2015-08-10 09:08:36 UTC
Updating this info as this bug is being marked for Sat6.1.z

Want to confirm the below:

a) upgrading sat6.0.8[rhel7.0] to sat6.1.1[rhel7.1] has no issues.
b) Sat6.1.1 did provide DHCP IP suggestions successfully even after upgrade.

Comment 11 Marek Hulan 2015-09-03 11:06:25 UTC
Kedar, the verification steps are correct, could you verify it please? I checked the foreman-debug and the dhcpd configuration seems correct. The only change that was made by installer was in the list of name servers in dhcpd.conf. Nothing else indicates that there's a configuration issue.

Comment 12 Sachin Ghai 2015-10-06 10:39:19 UTC
Verified with latest sat6.1.3 compose.

I upgraded the sat6.0.8 -> sat6.1.3 

After upgrade, sat6 offers IP address by clicking 'suggest new'. I don't find any issue with ip address assignment while creating new host.

production.log on clicking 'suggest new':
--
2015-10-06 06:34:57 [I] Processing by SubnetsController#freeip as JSON
2015-10-06 06:34:57 [I]   Parameters: {"subnet_id"=>"1", "host_mac"=>"", "organization_id"=>"1", "location_id"=>"2"}
2015-10-06 06:34:59 [I] Completed 200 OK in 2202ms (Views: 0.2ms | ActiveRecord: 4.4ms)
--

Please note that when you create new host, auto IP suggested by sat6 server.

Comment 13 Sachin Ghai 2015-10-06 10:41:14 UTC
Created attachment 1080197 [details]
IP offered by sat6

Comment 15 errata-xmlrpc 2015-10-15 18:19:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.