Bug 120292 - system boot fail with lvm2/jfs and latest kernel 2.6.4-1.305
system boot fail with lvm2/jfs and latest kernel 2.6.4-1.305
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Stephen Tweedie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 12:13 EDT by Per Olausson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 09:30:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log output (15.45 KB, text/plain)
2004-04-07 13:20 EDT, Per Olausson
no flags Details

  None (edit)
Description Per Olausson 2004-04-07 12:13:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007

Description of problem:
Have latest lvm2 and kernel from rawhide and on reboot it fails with
the message superblock is corrupt and cannot be repaired since both
primary and secondary copies are corrupt.

fsck.jfs is at 1.1.4.

Going back to previous kernel, everything is ok.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Reboot system
2.
3.
    

Actual Results:  CANNOT CONTINUE.

Expected Results:  System boot ok.

Additional info:
Comment 1 Stephen Tweedie 2004-04-07 12:18:15 EDT
Please supply the exact kernel log and error messages you get when the
problem occurs.  From the limited summary here, I can't tell if the
message is coming from the LVM layer or from JFS.
Comment 2 Per Olausson 2004-04-07 13:20:56 EDT
Created attachment 99199 [details]
dmesg log output
Comment 3 Per Olausson 2004-04-07 13:22:11 EDT
The log doesn't show much, is there some other log or how can I turn
on more?

Is the updated fedora kernel built with all the required modules for
lvm2 etc?
Comment 4 Stephen Tweedie 2004-04-07 16:16:11 EDT
You can set up a serial console to capture the full boot logs, or just
copy it down.  But we really need to see the actual error you're
getting, and that doesn't appear to be in the kernel logs here.
Comment 5 Per Olausson 2004-04-08 05:39:20 EDT
This is everything that is on screen. It's not much...

fsck.jfs version 1.1.4, 30-Oct-2003
processing started 4/8/2004 10.32.54
The current device is: /dev/mapper/rootvg-lvroot
Superblock is corrupt and cannot be repaired
since both primary and secondary copies are corrupt.

  CANNOT CONTINUE.

*** An error occurred during the file system check
*** Dropping you to a shell...
...
Comment 6 Stephen Tweedie 2004-04-08 10:36:38 EDT
Oh, so you do actually get to a shell prompt?  What does "ls -l
/dev/mapper/rootvg-lvroot" and "ls -l
/initrd/dev/mapper/rootvg-lvroot" show at that prompt, what does "cat
/proc/devices" show for the device-mapper entry?
Comment 7 Heiko Jakob 2004-06-24 02:09:37 EDT
How many volume groups do you have ? If you have more than 1
volumegroup Bug #126565 could be a duplicate. Do you have your "/" on
LVM ?

Regards Heiko
Comment 8 Alasdair Kergon 2004-08-31 09:30:02 EDT
No response; many changes since this was reported so closing.

Note You need to log in before you can comment on or make changes to this bug.