Bug 120294 - slurpd+TLS retry bug should be fixed
slurpd+TLS retry bug should be fixed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openldap (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 12:21 EDT by Phil D'Amore
Modified: 2015-01-07 19:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil D'Amore 2004-04-07 12:21:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
The current openldap shipped in RHEL3 (2.0.27) contains a bug in the
TLS retry code that was fixed in 2.1.24.  From the 2.1.24 changelog:

        Fixed slurpd TLS retry (ITS#2570)

In my testing this bug makes replication almost unusable if you are
trying to use TLS, and one of the replicas goes down and comes back
up, because when the connection re-establishes, it does not restart
TLS.  If you have your ssf settings set to require encryption, updates
begin to fail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up a master and one replica, using TLS for the updates, and
setting your SSF to require encryption for updates.
2. make some changes, see that they replicate
3. restart the slave daemon
4. make more changes on the master, and note that the updates are
rejected, the log of the replications reporting "Confidentiality
required".

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 15:27:57 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.