Bug 1203004 - [abrt] fig: __init__.py:810:resolve:ContextualVersionConflict: (requests 2.5.0 (/usr/lib/python2.7/site-packages), Requirement.parse('requests>=2.5.2'), set(['docker-py']))
Summary: [abrt] fig: __init__.py:810:resolve:ContextualVersionConflict: (requests 2.5....
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fig
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matej Stuchlik
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d263c26f99820715b3fcf49b0ac...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 21:31 UTC by james
Modified: 2016-02-01 02:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-31 08:05:57 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (3.38 KB, text/plain)
2015-03-17 21:31 UTC, james
no flags Details
File: environ (1.48 KB, text/plain)
2015-03-17 21:31 UTC, james
no flags Details

Description james 2015-03-17 21:31:51 UTC
Description of problem:
installed docker-io, and then fig

ran fig from a terminal - couldn't see it in whisker menu

got this

    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (requests 2.5.0 (/usr/lib/python2.7/site-packages), Requirement.parse('requests>=2.5.2'), set(['docker-py']))


Version-Release number of selected component:
fig-1.0.0-5.fc22

Additional info:
reporter:       libreport-2.4.0
cmdline:        /usr/bin/python2 /usr/bin/fig
dso_list:       python-setuptools-12.0.3-1.fc22.noarch
executable:     /usr/bin/fig
kernel:         4.0.0-0.rc3.git0.1.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
__init__.py:810:resolve:ContextualVersionConflict: (requests 2.5.0 (/usr/lib/python2.7/site-packages), Requirement.parse('requests>=2.5.2'), set(['docker-py']))

Traceback (most recent call last):
  File "/usr/bin/fig", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3018, in <module>
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 614, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 627, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 810, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (requests 2.5.0 (/usr/lib/python2.7/site-packages), Requirement.parse('requests>=2.5.2'), set(['docker-py']))

Local variables in innermost frame:
dist: requests 2.5.0 (/usr/lib/python2.7/site-packages)
to_activate: [fig 1.0.0 (/usr/lib/python2.7/site-packages), six 1.9.0 (/usr/lib/python2.7/site-packages), docker-py 1.1.0 (/usr/lib/python2.7/site-packages), websocket-client 0.14.1 (/usr/lib/python2.7/site-packages), texttable 0.8.1 (/usr/lib/python2.7/site-packages), requests 2.5.0 (/usr/lib/python2.7/site-packages), PyYAML 3.11 (/usr/lib64/python2.7/site-packages), docopt 0.6.1 (/usr/lib/python2.7/site-packages)]
req: Requirement.parse('requests>=2.5.2')
requirements: [Requirement.parse('backports.ssl-match-hostname'), Requirement.parse('six')]
new_requirements: []
replace_conflicting: False
required_by: defaultdict(<type 'set'>, {Requirement.parse('backports.ssl-match-hostname'): set(['websocket-client']), Requirement.parse('requests>=2.2.1'): set(['fig']), Requirement.parse('websocket-client>=0.11.0'): set(['docker-py', 'fig']), Requirement.parse('PyYAML>=3.10'): set(['fig']), Requirement.parse('six'): set(['websocket-client']), Requirement.parse('requests>=2.5.2'): set(['docker-py']), Requirement.parse('docker-py>=0.5'): set(['fig']), Requirement.parse('six>=1.3.0'): set(['docker-py', 'fig']), Requirement.parse('docopt>=0.6.1'): set(['fig']), Requirement.parse('texttable>=0.8.1'): set(['fig'])})
ws: <pkg_resources.WorkingSet object at 0x7f129645e410>
new_requirement: Requirement.parse('six')
env: <pkg_resources.Environment object at 0x7f129645ed50>
installer: None
dependent_req: set(['docker-py'])
self: <pkg_resources.WorkingSet object at 0x7f129645e410>
best: {'docker-py': docker-py 1.1.0 (/usr/lib/python2.7/site-packages), 'pyyaml': PyYAML 3.11 (/usr/lib64/python2.7/site-packages), 'six': six 1.9.0 (/usr/lib/python2.7/site-packages), 'fig': fig 1.0.0 (/usr/lib/python2.7/site-packages), 'texttable': texttable 0.8.1 (/usr/lib/python2.7/site-packages), 'docopt': docopt 0.6.1 (/usr/lib/python2.7/site-packages), 'requests': requests 2.5.0 (/usr/lib/python2.7/site-packages), 'websocket-client': websocket-client 0.14.1 (/usr/lib/python2.7/site-packages)}
processed: {Requirement.parse('requests>=2.2.1'): True, Requirement.parse('websocket-client>=0.11.0'): True, Requirement.parse('PyYAML>=3.10'): True, Requirement.parse('docker-py>=0.5'): True, Requirement.parse('six>=1.3.0'): True, Requirement.parse('fig==1.0.0'): True, Requirement.parse('docopt>=0.6.1'): True, Requirement.parse('texttable>=0.8.1'): True}

Comment 1 james 2015-03-17 21:31:54 UTC
Created attachment 1002959 [details]
File: backtrace

Comment 2 james 2015-03-17 21:31:55 UTC
Created attachment 1002960 [details]
File: environ

Comment 3 Matej Stuchlik 2015-03-18 10:33:26 UTC
This seems to be a problem with docker-py and python-requests. Docker-py's setup.py requires python-requests >= 2.5.2, which is a problem, because in f22 we currently only have python-requests-2.5.0-3.

Could you please try if [0] resolves the issue for you? And if it does, giving it positive karma?

[0] https://admin.fedoraproject.org/updates/FEDORA-2015-4076/python-requests-2.5.3-2.fc22,python-urllib3-1.10.2-1.fc22?_csrf_token=b2599df59518c132e8cfd54561dfc1cd992bac5c

Comment 4 Matej Stuchlik 2015-08-31 08:05:57 UTC
Fig has been replaced by docker-compose, which is not affected by this issue.


Note You need to log in before you can comment on or make changes to this bug.