Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1203111 - Sync plan page shows incorrect count of Total plans after deleting the sync plans.
Summary: Sync plan page shows incorrect count of Total plans after deleting the sync p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-18 06:51 UTC by Jitendra Yejare
Modified: 2019-09-25 21:28 UTC (History)
1 user (show)

Fixed In Version: rubygem-katello-3.0.0.27-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:32:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of Sync Plans page showing an incorrect Total Count of Sync plans. (97.44 KB, image/png)
2015-03-18 06:51 UTC, Jitendra Yejare
no flags Details
Satellite 6.1.1: Sync plans before delete (56.63 KB, image/png)
2015-09-02 18:42 UTC, Brad Buckingham
no flags Details
Satellite 6.1.1: Sync plans after delete (55.21 KB, image/png)
2015-09-02 18:42 UTC, Brad Buckingham
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 14902 0 None None None 2016-05-02 15:00:51 UTC

Description Jitendra Yejare 2015-03-18 06:51:54 UTC
Created attachment 1003079 [details]
Screenshot of Sync Plans page showing an incorrect Total Count of Sync plans.

Description of problem:
The Sync plan shows an incorrect number(count) of Total plans present on the page in label 'Showing <number> of <TotalCount>' also goes into minus.

Version-Release number of selected component (if applicable):
Satellite 6.1 Snap 6 Compose 2.

How reproducible:
Always

Steps to Reproduce:
1. Create 2 Sync plans from Content -> Sync Plans page.
2. Delete both of them.
3. Observe the total count in label 'Showing <num> of <TotalCount>'.

Actual results:
The Sync plan shows an incorrect number(count) of Total plans present on the page in label 'Showing <number> of <TotalCount>' also goes into minus.

Expected results:
The Total Count of sync plans on the page should be correct in label 'Showing <num> of <TotalCount>'.

Comment 2 Brad Buckingham 2015-09-02 18:41:44 UTC
I have tested this on a Satellite 6.1.1 GA install and am no longer observing
the behavior described.

RPMs:
ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
foreman-1.7.2.34-1.el7sat.noarch

Updated screenshots attached.

Comment 3 Brad Buckingham 2015-09-02 18:42:15 UTC
Created attachment 1069572 [details]
Satellite 6.1.1: Sync plans before delete

Comment 4 Brad Buckingham 2015-09-02 18:42:44 UTC
Created attachment 1069573 [details]
Satellite 6.1.1: Sync plans after delete

Comment 5 Jitendra Yejare 2016-03-14 10:23:12 UTC
I tested this on latest Satellite 6.2 snap 3 beta.

I can see issue is still reproducible.

After adding two syn plans it shows 'Showing 2 of 0 (0 Total)' <- This is incorrect.

After Removing it shows properly now as 0 of 0.

I am using firefox to repro this issue.

Comment 6 Brad Buckingham 2016-03-14 13:28:24 UTC
Thanks Jitendra.  I was able to reproduce on upstream master now as well.

Comment 7 Walden Raines 2016-05-02 14:35:18 UTC
Created redmine issue http://projects.theforeman.org/issues/14902 from this bug

Comment 8 Walden Raines 2016-05-02 14:48:38 UTC
PR - https://github.com/Katello/katello/pull/6009

Comment 9 Walden Raines 2016-05-04 13:08:05 UTC
This should be in POST:

Revision a29e6105
Added by Walden Raines 2 days ago

Fixes #14902: refresh nutupane when adding/removing sync plans

The nutupane table wasn't being refreshed when adding or removing
sync plans and thus the count was off. This commit refreshes the
nutupane after altering the total number of sync plans.

http://projects.theforeman.org/issues/14902

Revision 8284fe2e
Added by Walden Raines about 15 hours ago

Merge pull request #6009 from waldenraines/14902

Fixes #14902: refresh nutupane when adding or removing sync plans.

Comment 10 Jitendra Yejare 2016-06-24 07:16:37 UTC
Verified.

@Sat 6.2 Snap 17

I added two sync plans and deleted them. The total count while adding/deleting and after adding/deleting is shown correctly.

So moving this bz to verified state.

Comment 11 Bryan Kearney 2016-07-27 11:32:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.