Bug 1203118 - Lazarus crashes on startup with "g_object_unref: assertion 'G_IS_OBJECT (object)' failed"
Summary: Lazarus crashes on startup with "g_object_unref: assertion 'G_IS_OBJECT (obje...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 22
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1206359 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-18 07:25 UTC by Heiko Adams
Modified: 2015-04-06 14:45 UTC (History)
9 users (show)

Fixed In Version: fontconfig-2.11.93-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-31 21:47:40 UTC


Attachments (Terms of Use)
Lazarus backtrace (8.82 KB, text/plain)
2015-03-18 18:49 UTC, Heiko Adams
no flags Details

Description Heiko Adams 2015-03-18 07:25:54 UTC
Description of problem:
When launching lazarus it crashes with "(lazarus-ide:3953): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed"

Version-Release number of selected component (if applicable):
$ rpm -q lazarus
lazarus-1.2-4.fc22.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Open a terminal
2. start lazarus
3.

Actual results:
Lazarus crashes with the described error message

Expected results:
Lazarus should start without crashing

Additional info:
This also affects all binaries built with lazarus

Comment 1 Heiko Adams 2015-03-18 18:49:17 UTC
Created attachment 1003380 [details]
Lazarus backtrace

I tried to create a backtrace of the crash. Maybe that helps solving the problem

Comment 2 Heiko Adams 2015-03-25 10:43:01 UTC
*ping*

Comment 3 Vít Ondruch 2015-03-25 14:31:56 UTC
Neither the recent version of lazarus works :/

$ lazarus-ide

(lazarus-ide:9770): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00007FE3D2F33DE0
TApplication.HandleException Access violation
  Stack trace:
  $00007FE3D2F33DE0
[FORMS.PP] ExceptionOccurred


$ rpm -q lazarus
lazarus-1.4-0.1.RC2.fc23.x86_64

Comment 4 Joost van der Sluis 2015-03-26 17:04:00 UTC
I was about to merge Lazarus 1.4 to the F22 branch, but since that version also fails...

I've reported it upstream. I hope it can be fixed before the final release of Lazarus 1.4.

Comment 5 Vít Ondruch 2015-03-27 08:19:01 UTC
(In reply to Joost van der Sluis from comment #4)
> I've reported it upstream. I hope it can be fixed before the final release
> of Lazarus 1.4.

Thanks. Would you mind to share the link to the ticket.

Also, if I remember correctly, the issues began with gtk2-2.24.26-1.fc23. All the previous versions were just fine.

Comment 6 Joost van der Sluis 2015-03-27 13:06:07 UTC
(In reply to Vít Ondruch from comment #5)
> Thanks. Would you mind to share the link to the ticket.

I did not use the bug-tracker, but send it directly to the development-list: 

http://lists.lazarus.freepascal.org/pipermail/lazarus/2015-March/091548.html

One of the developers there thinks that it's an issue in pango/gtk, not Lazarus.
 
> Also, if I remember correctly, the issues began with gtk2-2.24.26-1.fc23.
> All the previous versions were just fine.

That info could be relevant. But I don't know how to proceed now...

Comment 7 Vít Ondruch 2015-03-27 13:48:59 UTC
I tried to downgrade pango, but it does not help. I can't downgrade gtk2, since it would downgrade half of my system :/

The Python issue is GDB thing IMO, so nothing to worry about.

BTW, since I am using Double Commander and it crashes in similar manner, this is the backtrace I got:

#0  0x00007ffff45e7a0a in FcRangeHash () from /lib64/libfontconfig.so.1
#1  0x00007ffff45e5629 in FcPatternHash () from /lib64/libfontconfig.so.1
#2  0x00007ffff6dd9e33 in g_hash_table_lookup () from /lib64/libglib-2.0.so.0
#3  0x00007ffff4815276 in uniquify_pattern () from /lib64/libpangoft2-1.0.so.0
#4  0x00007ffff4816bda in pango_fc_fontset_get_font_at () from /lib64/libpangoft2-1.0.so.0
#5  0x00007ffff481709d in pango_fc_fontset_foreach () from /lib64/libpangoft2-1.0.so.0
#6  0x00007ffff4815409 in pango_fc_font_map_load_font () from /lib64/libpangoft2-1.0.so.0
#7  0x00007ffff6749a3f in pango_layout_get_empty_extents_at_index () from /lib64/libpango-1.0.so.0
#8  0x00007ffff674d24f in pango_layout_line_get_extents () from /lib64/libpango-1.0.so.0
#9  0x00007ffff674f45f in get_line_extents_layout_coords () from /lib64/libpango-1.0.so.0
#10 0x00007ffff674f5de in pango_layout_get_extents_internal () from /lib64/libpango-1.0.so.0
#11 0x00007ffff766cb7c in gtk_label_size_request () from /lib64/libgtk-x11-2.0.so.0
#12 0x00007ffff70edbde in g_cclosure_marshal_VOID__BOXEDv () from /lib64/libgobject-2.0.so.0
#13 0x00007ffff70eaf42 in _g_closure_invoke_va () from /lib64/libgobject-2.0.so.0
#14 0x00007ffff7105b9d in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#15 0x00007ffff71066a5 in g_signal_emit_by_name () from /lib64/libgobject-2.0.so.0
#16 0x00007ffff76f0bca in _gtk_size_group_compute_requisition () from /lib64/libgtk-x11-2.0.so.0
#17 0x00007ffff77b9ea5 in gtk_window_size_request () from /lib64/libgtk-x11-2.0.so.0
#18 0x00007ffff70edbde in g_cclosure_marshal_VOID__BOXEDv () from /lib64/libgobject-2.0.so.0
#19 0x00007ffff70eaff4 in _g_closure_invoke_va () from /lib64/libgobject-2.0.so.0
#20 0x00007ffff7105b9d in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#21 0x00007ffff71066a5 in g_signal_emit_by_name () from /lib64/libgobject-2.0.so.0
#22 0x00007ffff76f0bca in _gtk_size_group_compute_requisition () from /lib64/libgtk-x11-2.0.so.0
#23 0x00007ffff77b8b8d in gtk_window_compute_configure_request () from /lib64/libgtk-x11-2.0.so.0
#24 0x00007ffff77ba9f5 in gtk_window_show () from /lib64/libgtk-x11-2.0.so.0
#25 0x00007ffff70eadc5 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#26 0x00007ffff70fce2d in signal_emit_unlocked_R () from /lib64/libgobject-2.0.so.0
#27 0x00007ffff7105e10 in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#28 0x00007ffff71061df in g_signal_emit () from /lib64/libgobject-2.0.so.0
#29 0x00007ffff77aec96 in gtk_widget_show () from /lib64/libgtk-x11-2.0.so.0
#30 0x000000000064a197 in ?? ()
#31 0x0000000000000000 in ?? ()

Comment 8 Mattia Verga 2015-03-28 17:20:09 UTC
I tried to downgrade a lot of stuff to the same version of F21 where lazarus-ide works fine:
gtk2-2.24.27-1.fc22.x86_64
pango-1.36.7-1.fc22.x86_64
cairo-1.14.0-2.fc22.x86_64
python-2.7.8-9.fc22.x86_64
pygtk2-2.24.0-11.fc22.x86_64
glibc-2.19.90-36.fc22.x86_64
glib2-2.42.0-1.fc22.x86_64

Nothing works... after downgrading glib2 the error is a bit changed:

(lazarus-ide:7714): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[FORMS.PP] ExceptionOccurred
  Sender=EDivByZero
  Exception=Division by zero
  Stack trace:
  $000000337C81FA0A
TApplication.HandleException Division by zero
  Stack trace:
  $000000337C81FA0A
[FORMS.PP] ExceptionOccurred

I'm using skychart that crashes in the same manner. I tried to rebuild skychart with the downgraded stuff, but it doesn't help, so the error is neither in the building process.

Comment 9 Mattia Verga 2015-03-28 17:22:19 UTC
*** Bug 1206359 has been marked as a duplicate of this bug. ***

Comment 10 Mattia Verga 2015-03-29 10:16:30 UTC
OK, I found it! Downgrading to fontconfig-2.11.1-5.fc22.x86_64 solves the bug.

So, the problem is in fontconfig package. I will change the component in bugzilla.

Comment 11 Mattia Verga 2015-03-29 12:17:36 UTC
As a side note: you should also downgrade to pango-1.36.8-1, which is the latest version built with fontconfig-2.11.1-5.

The more recent pango-1.36.8-2 does not work with downgraded fontconfig.

Comment 12 Fedora Update System 2015-03-30 10:52:31 UTC
fontconfig-2.11.93-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/fontconfig-2.11.93-2.fc22

Comment 13 Heiko Adams 2015-03-30 10:53:28 UTC
fontconfig update solves the problem

Comment 14 Vít Ondruch 2015-03-31 06:28:34 UTC
I can confirm that double commander runs again with fontconfig-2.11.93-2.fc23.x86_64 and pango-1.36.8-3.fc23.x86_64. Thank you guys.

Comment 15 Fedora Update System 2015-03-31 21:47:40 UTC
fontconfig-2.11.93-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Akira TAGOH 2015-04-06 12:31:10 UTC
See what?


Note You need to log in before you can comment on or make changes to this bug.