Bug 120314 - xmms cannot output when run by normal user
Summary: xmms cannot output when run by normal user
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policy   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-07 18:56 UTC by Albert Strasheim
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-28 14:29:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Albert Strasheim 2004-04-07 18:56:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Playing MP3s (using a third party xmms-mp3 RPM) works fine as root
(i.e. you can hear the MP3).

When trying to play MP3s as a normal user with the ALSA output plugin
selected, XMMS outputs the following message to stdout:

** WARNING **: alsa_setup(): Failed to open pcm device (default):
Permission denied

Similar warnings are displayed for other output plugins, such as for OSS:

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp):
Permission denied


Version-Release number of selected component (if applicable):
policy-1.9.2-12 xmms-1.2.10-2.p

How reproducible:
Always

Steps to Reproduce:
1. Start xmms as normal user
2. Play sound
    

Actual Results:  xmms is unable to play the sound because of
permissions problems

Expected Results:  xmms should play sounds when run by a normal user

Additional info:

No policy warnings appear in /var/log/messages. xmms still doesn't
work with setenforce 0.

Maybe this is not a policy problem?

Comment 1 Daniel Walsh 2004-04-08 13:06:36 UTC
Could you relabel the /dev/ directory.  I beliece we have a problem
with the latest udev rewriting files on /dev and loosing the file context.

setfiles /etc/security/selinux/file_contexts /dev

We have a bug report in on udev.

Dan

Comment 2 Leonard den Ottolander 2004-05-10 17:50:36 UTC
What's the status on this one? Did the relabeling of /dev solved your
issues?



Note You need to log in before you can comment on or make changes to this bug.