Bug 1203151 - Duplicated output for already installed packages
Summary: Duplicated output for already installed packages
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 22
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Luscon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1205863 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-18 09:31 UTC by Michael Mráka
Modified: 2015-05-08 07:33 UTC (History)
7 users (show)

Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 18:48:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Mráka 2015-03-18 09:31:11 UTC
Description of problem:
Duplicated output lines in dnf builddep.

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.5-1.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf builddep hawkey-0.5.3-1.git.0.a1c50e5.fc22.src.rpm
2.
3.

Actual results:
# dnf builddep /tmp/tito/hawkey-0.5.3-1.git.0.a1c50e5.fc22.src.rpm
Using metadata from Tue Mar 17 03:55:06 2015
Package cmake-3.2.1-1.fc22.x86_64 is already installed, skipping.
Package cmake-3.2.1-1.fc22.x86_64 is already installed, skipping.
Package cmake-3.2.1-1.fc22.x86_64 is already installed, skipping.
Package expat-devel-2.1.0-10.fc22.x86_64 is already installed, skipping.
Package expat-devel-2.1.0-10.fc22.x86_64 is already installed, skipping.
Package expat-devel-2.1.0-10.fc22.x86_64 is already installed, skipping.
Package rpm-devel-4.12.0.1-7.fc22.x86_64 is already installed, skipping.
Package rpm-devel-4.12.0.1-7.fc22.x86_64 is already installed, skipping.
Package rpm-devel-4.12.0.1-7.fc22.x86_64 is already installed, skipping.
Package zlib-devel-1.2.8-7.fc22.x86_64 is already installed, skipping.
Package zlib-devel-1.2.8-7.fc22.x86_64 is already installed, skipping.
Package zlib-devel-1.2.8-7.fc22.x86_64 is already installed, skipping.
Dependencies resolved.
==========================================================================================================
 Package                              Arch    Version                              Repository        Size
==========================================================================================================
Installing:
 check                                x86_64  0.9.14-2.fc22                        fedora           147 k
 check-devel                          x86_64  0.9.14-2.fc22                        fedora            30 k
...

Expected results:
# dnf builddep /tmp/tito/hawkey-0.5.3-1.git.0.a1c50e5.fc22.src.rpm
Using metadata from Tue Mar 17 03:55:06 2015
Package cmake-3.2.1-1.fc22.x86_64 is already installed, skipping.
Package expat-devel-2.1.0-10.fc22.x86_64 is already installed, skipping.
Package rpm-devel-4.12.0.1-7.fc22.x86_64 is already installed, skipping.
Package zlib-devel-1.2.8-7.fc22.x86_64 is already installed, skipping.
Dependencies resolved.
==========================================================================================================
 Package                              Arch    Version                              Repository        Size
==========================================================================================================
Installing:
 check                                x86_64  0.9.14-2.fc22                        fedora           147 k
 check-devel                          x86_64  0.9.14-2.fc22                        fedora            30 k
...



Additional info:
There are no duplicates in srpm requires.
# rpm -qp --requires  /tmp/tito/hawkey-0.5.3-1.git.0.a1c50e5.fc22.src.rpm
check-devel
cmake
expat-devel
libsolv-devel >= 0.6.4-1
python-nose
python-sphinx >= 1.1.3-9
python2-devel
python3-devel
python3-nose
python3-sphinx >= 1.1.3-9
rpm-devel
rpmlib(CompressedFileNames) <= 3.0.4-1
zlib-devel

Comment 1 Radek Holy 2015-03-18 11:32:48 UTC
This is not specific to DNF plugins. The bug was introduced by a commit 752c50b.

Comment 2 Michal Luscon 2015-03-18 12:41:37 UTC
Fixed in PR #222.

Comment 3 Radek Holy 2015-03-26 08:57:38 UTC
*** Bug 1205863 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2015-03-31 18:17:36 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 5 Fedora Update System 2015-04-02 01:43:52 UTC
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-03 11:39:02 UTC
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 7 Fedora Update System 2015-04-06 18:48:47 UTC
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-04-16 09:05:15 UTC
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21

Comment 9 Fedora Update System 2015-05-08 07:33:15 UTC
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.