Bug 1203176 - RHEV-H hypervisor is not showing the local disk
Summary: RHEV-H hypervisor is not showing the local disk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
: 1208200 (view as bug list)
Depends On:
Blocks: 1235351
TreeView+ depends on / blocked
 
Reported: 2015-03-18 10:33 UTC by nijin ashok
Modified: 2019-12-16 04:41 UTC (History)
16 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
The Red Hat Enterprise Virtualization Hypervisor (RHEV-H) could not be installed on systems with more than 26 disks in /dev (including multiple paths to the same disk) due to the local disk being filtered out of the installer. The filtering now operates on single disks instead of lists of disks ensuring that RHEV-H can be installed.
Clone Of:
: 1235351 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:18:32 UTC
oVirt Team: Node
Target Upstream Version:
mgoldboi: Triaged+


Attachments (Terms of Use)
four pictures about RAID details and Installation details. (120.00 KB, application/x-tar)
2015-03-19 09:00 UTC, Mengde Shang
no flags Details
localdiskandFC.png (18.30 KB, image/png)
2015-06-16 14:41 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 1401363 None None None 2019-05-20 11:40:50 UTC
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 42397 None None None Never
oVirt gerrit 42819 ovirt-3.5 MERGED Rework detection of multipath disks to remove in the installer Never

Comment 1 Fabian Deutsch 2015-03-18 13:18:47 UTC
Once we have a fix, we can probably consider this bug for a z-stream.

Comment 7 Mengde Shang 2015-03-19 09:00:49 UTC
Created attachment 1003747 [details]
four pictures about RAID details and Installation details.

Can not reproduce the bug.

Version-Release number of selected component:
rhev-hypervisor6-6.6-20150128

Hardware: IBM System x3650 M4 with RAID 1
http://ibm-x3650m4-01-imm.qe.lab.eng.nay.redhat.com

Actual Result:
The local disk can be detect during TUI installation and the installation of rhev-hypervisor6-6.6-20150128 was succeed.

details can check in this attachment.

Comment 33 Ryan Barry 2015-06-15 17:23:15 UTC
*** Bug 1208200 has been marked as a duplicate of this bug. ***

Comment 38 Ying Cui 2015-06-16 14:41:08 UTC
Created attachment 1039504 [details]
localdiskandFC.png

Tested pass on builds provided on comment 35.
Test env. Emulex FC HBA and with _15_ luns with 2 paths and _one_ local disk.
The local disk can be detected now.

Comment 42 Ying Cui 2015-11-02 11:17:28 UTC
Verified this bug on rhevh 7.2-20151025(ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev)

Test env. Emulex FC HBA and with _15_ luns with 2 paths and _one_ local disk on IBM 3560M4(this bug depends on how much luns but not related hardware.)

Steps:
1. TUI install rhevh.
2. Navigate to rhevh boot disk selection and installation disk selection pages

These 15 luns and local disks can be detected now.

Comment 44 errata-xmlrpc 2016-03-09 14:18:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.