Bug 1203181 - (6.4.z) Handle SOAP Fault properly for 400 in SOAP 1.1 and 1.2
Summary: (6.4.z) Handle SOAP Fault properly for 400 in SOAP 1.1 and 1.2
Keywords:
Status: CLOSED DUPLICATE of bug 1182919
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: baranowb
QA Contact: Rostislav Svoboda
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-18 10:46 UTC by baranowb
Modified: 2016-02-08 14:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-15 09:14:44 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker JBWS-3887 0 Major Closed Handle SOAP Fault properly for 400 in SOAP 1.1 and 1.2 2016-02-08 14:31:16 UTC

Description baranowb 2015-03-18 10:46:00 UTC
Based on asoldano comment: https://bugzilla.redhat.com/show_bug.cgi?id=1151526#c17

'My opinion is that we need a CXF jira for the changes not strictly related to our JBossWS SOAPConnectionImpl (it should be checked if the Soap11FaultInInterceptor should actually be rejecting http 400 messages) and a JBWS jira for the rest of the changes.'

Comment 4 baranowb 2015-05-11 13:45:33 UTC
Re-Add to WS upgrade and 6.4.2 payload

Comment 9 Rostislav Svoboda 2015-05-27 07:24:14 UTC
https://issues.apache.org/jira/browse/CXF-6198 still unresolved, upstream is not sure how to proceed.

Comment 10 Rostislav Svoboda 2015-05-28 08:39:10 UTC
Removing from eap642-payload and JBossWS CXF 4.3.5.Final component upgrade BZ. Discussed via email with Bartosz a Alessio, no upstream activity. Changes won't be merged, we will wait for action from CXF team.

JBossWS CXF 4.3.5.Final tag is already available - http://anonsvn.jboss.org/repos/jbossws/stack/cxf/tags/jbossws-cxf-4.3.5.Final

Comment 16 Ivo Studensky 2015-12-15 09:14:44 UTC

*** This bug has been marked as a duplicate of bug 1182919 ***


Note You need to log in before you can comment on or make changes to this bug.