Bug 1203214 - Improve not supported messages for block migration
Summary: Improve not supported messages for block migration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: Gu Nini
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-18 12:14 UTC by Dr. David Alan Gilbert
Modified: 2018-07-03 16:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-03 16:24:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dr. David Alan Gilbert 2015-03-18 12:14:18 UTC
Description of problem:
If you attempt to do a old-type block migration on qemu-kvm or qemu-kvm-rhev you currently get an error like:

'unable to execute QEMU command 'migrate': this feature or command is not currently supported'

it doesn't tell the user what the error

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.  perform a migration that turns out to use qemu old school block migration; i.e. any non-shared storage on qemu-kvm or tunnelled on qemu-kvm-rhev

Actual results:
'unable to execute QEMU command 'migrate': this feature or command is not currently supported'

Expected results:
'unable to execute QEMU command 'migrate': QEMU block migration is unsupported in this version; please use shared storage or NBD based migration
(where the NBD is only displayed for -rhev)

Additional info:

Comment 4 Dr. David Alan Gilbert 2017-05-03 10:52:04 UTC
Posted upstream:
block migration: Allow compile time disable

which prints:
 QEMU compiled without old-style block migration. Use drive_mirror+NBD.


Note You need to log in before you can comment on or make changes to this bug.