Bug 120348 - redhat-menus should conflicts with older gnome-vfs2
redhat-menus should conflicts with older gnome-vfs2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 17:50 EDT by Kir Kolyshkin
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 05:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kir Kolyshkin 2004-04-07 17:50:26 EDT
redhat-menus now contains .menu files in /etc/xdg/menus/ directory;
previously the location for these files was /etc/X11/desktop-menus/.

But some old packages have old path hardcoded; on my system I found
some of those: gnome-vfs2-2.5.8-2 (in libvfolder-desktop.so) and
kernel-utils-2.4-9.1.115 (in /etc/readahead.files).

The problem is redhat-menus neither require newer versions of those
packages, nor conflicts with older versions.  So upgrading
redhat-menus works fine, but when menus are disappearing. I think
"Conflicts:" is a better thing to do as redhat-menus doesn't require
anything.

So I belive that would be great to add to redhat-menus.spec the
following lines:

Conflicts: gnome-vfs2 < 2.6.0-1
Conflicts: kernel-utils < 2.4-9.1.126

While kernel-utils conflict is optional, gnome-vfs2 is really required
as it breaks menus otherwise.

I have put a current version/release for kernel-utils; actually
there's a bug in kernel-utils (bug #120347), it should be corrected
and release above should be bumped.
Comment 1 Bryan W Clark 2005-01-05 14:38:53 EST
is this still a problem with the current releases?
Comment 2 Bryan W Clark 2005-01-05 15:12:52 EST
Also, does 
<LegacyDir>/etc/X11/desktop-menus/</LegacyDir>

help when added to /etc/xdg/menus/applications.menu
Comment 3 Kir Kolyshkin 2005-01-05 15:32:46 EST
This bug was not actually a bug about wrong location for .menu files
in some packages.

This was a suggestion (or call it enhancement request) to put a few
'Conflicts:' lines in redhat-menus.spec so it will 'conflict' with
older packages that relied on the old path to .menu files. That would
result in inability to upgrade redhat-menus if there are packages that
rely on the old path.

This suggestion definitely made sense 8 months ago for all rawhide
users. Now it doesn't make sense since every package is using
/etc/xdg/menus now and everybody should be already upgraded by now anyway.

So I'd close it as WONTFIX.

PS I doubt your suggestion about LegacyDir would help, since, say, old
gnome-vfs2 _explicitly_ looks for stuff in /etc/X11/desktop-menus/,
and adding something to some file in other directory doesn't make
sense (at least in this situation).
Comment 4 Mickey Stein 2005-02-03 12:27:27 EST
As of now on rawhide, it appears that gnome-menus conflicts with
redhat-menus. Both have identical files in /etc/xdg/menus that appear
happy to clobber each other. Last one in wins. 

I was running kde, applied the gnome-menu's update, and had a
completely foreign set of menus in kde. I downloaded redhat-menus,
extracted all the files, and copied over the xml from the above
directory, and it was all restored. This may only be a problem for
those of us using pieces of gnome (because they're dependencies), but
using the kde desktop. 

Regard *vfs*, it doesn't appear to me that it has xdg entries anymore. 

Mick

Note You need to log in before you can comment on or make changes to this bug.