Bug 1203597 - Augeas fails to parse /etc/krb5.conf with "{}" in the value
Summary: Augeas fails to parse /etc/krb5.conf with "{}" in the value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: augeas
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1066419
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 08:50 UTC by Hu Zhang
Modified: 2015-07-22 05:41 UTC (History)
2 users (show)

Fixed In Version: augeas-1.0.0-10.el6
Doc Type: Bug Fix
Doc Text:
Cause: /etc/krb5.conf configuration files containing {} in values Consequence: Augeas was unable to parse these krb5.conf files Fix: Augeas' lens (parser) has been fixed to handle {} in krb5.conf setting values Result: Augeas can now parse these krb5.conf files
Clone Of:
Environment:
Last Closed: 2015-07-22 05:41:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1256 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-07-20 17:50:00 UTC

Description Hu Zhang 2015-03-19 08:50:45 UTC
Description of problem:
Augeas fails to parse /etc/krb5.conf when there is any "{" and "}" in the value.


Version-Release number of selected component (if applicable):
augeas-1.0.0-9.el6.x86_64


How reproducible:
always


Steps to Reproduce:
1. Add the following line in the [logging] section
kdc = FILE:/var/log/krb{5}kdc.log

2. Try to parse /etc/krb5.conf
# augtool print /augeas/files/etc/krb5.conf

Actual results:
/augeas/files/etc/krb5.conf
/augeas/files/etc/krb5.conf/path = "/files/etc/krb5.conf"
/augeas/files/etc/krb5.conf/mtime = "1426151374"
/augeas/files/etc/krb5.conf/lens = "@Krb5"
/augeas/files/etc/krb5.conf/lens/info = "/usr/share/augeas/lenses/dist/krb5.aug:152.10-154.66:"
/augeas/files/etc/krb5.conf/error = "parse_failed"
/augeas/files/etc/krb5.conf/error/pos = "123"
/augeas/files/etc/krb5.conf/error/line = "5"
/augeas/files/etc/krb5.conf/error/char = "0"
/augeas/files/etc/krb5.conf/error/lens = "/usr/share/augeas/lenses/dist/krb5.aug:152.10-154.66:"
/augeas/files/etc/krb5.conf/error/message = "Get did not match entire input"

Expected results:
Augeas can parse /etc/krb5.conf successfully even there is any "{" and "}" in the value.

Additional info:

Comment 1 Dominic Cleal 2015-03-19 09:26:17 UTC
Fixed in d9465ab and in RHEL 7.0 already via bug #1066419.

Comment 3 Hu Zhang 2015-05-05 05:55:28 UTC
Verify with augeas-1.0.0-10.el6

Steps to verify:
1. Add the following line in the [logging] section
kdc = FILE:/var/log/krb{5}kdc.log

2. Try to parse /etc/krb5.conf
# augtool print /files/etc/krb5.conf
/files/etc/krb5.conf
/files/etc/krb5.conf/logging
/files/etc/krb5.conf/logging/default
/files/etc/krb5.conf/logging/default/file = "/var/log/krb5libs.log"
/files/etc/krb5.conf/logging/kdc[1]
/files/etc/krb5.conf/logging/kdc[1]/file = "/var/log/krb5kdc.log"
/files/etc/krb5.conf/logging/admin_server
/files/etc/krb5.conf/logging/admin_server/file = "/var/log/kadmind.log"
/files/etc/krb5.conf/logging/kdc[2]
/files/etc/krb5.conf/logging/kdc[2]/file = "/var/log/krb{5}kdc.log"
/files/etc/krb5.conf/libdefaults
/files/etc/krb5.conf/libdefaults/default_realm = "EXAMPLE.COM"
/files/etc/krb5.conf/libdefaults/dns_lookup_realm = "false"
/files/etc/krb5.conf/libdefaults/dns_lookup_kdc = "false"
/files/etc/krb5.conf/libdefaults/ticket_lifetime = "24h"
/files/etc/krb5.conf/libdefaults/renew_lifetime = "7d"
/files/etc/krb5.conf/libdefaults/forwardable = "true"
/files/etc/krb5.conf/realms
/files/etc/krb5.conf/realms/realm = "EXAMPLE.COM"
/files/etc/krb5.conf/realms/realm/kdc = "kerberos.example.com"
/files/etc/krb5.conf/realms/realm/admin_server = "kerberos.example.com"
/files/etc/krb5.conf/domain_realm
/files/etc/krb5.conf/domain_realm/.example.com = "EXAMPLE.COM"
/files/etc/krb5.conf/domain_realm/example.com = "EXAMPLE.COM"

Parsed successfully. So fixed.

Comment 5 errata-xmlrpc 2015-07-22 05:41:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1256.html


Note You need to log in before you can comment on or make changes to this bug.