Bug 1203648 - Quota: Build ancestry in the lookup
Summary: Quota: Build ancestry in the lookup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: sharding
Version: 3.6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1184885 1203589 1222847
Blocks: 1056085 glusterfs-3.6.3 1224138
TreeView+ depends on / blocked
 
Reported: 2015-03-19 10:42 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:49 UTC (History)
3 users (show)

Fixed In Version: glusterfs-v3.6.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1184885
Environment:
Last Closed: 2016-02-04 15:20:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-03-19 10:47:48 UTC
REVIEW: http://review.gluster.org/9943 (Quota: Build ancestry in the lookup) posted (#1) for review on release-3.6 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-03-25 08:54:48 UTC
COMMIT: http://review.gluster.org/9943 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 0799f5f6091c09361fe0bc394fe614ee55d67296
Author: vmallika <vmallika@redhat.com>
Date:   Thu Mar 19 07:32:33 2015 +0530

    Quota: Build ancestry in the lookup
    
    This is a backport of http://review.gluster.org/#/c/9478/
    
    > Marker can fail or can account incorrect numbers when it doesn't find a
    > ancestry for a inode.
    >
    > Solution:
    > Current build_ancestry is done only on demand in the write/create FOPs
    > in quota enforcer.
    > It is good to do this in the quota_lookup as well.
    >
    > Change-Id: I8aaf5b3e05a3ca51e7ab1eaa1b636a90f659a872
    > BUG: 1184885
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/9478
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    > Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    
    Change-Id: I57d3f801996da7194f5290067ff367888994786d
    BUG: 1203648
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/9943
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 3 Kaushal 2016-02-04 15:20:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.3, please open a new bug report.

glusterfs-v3.6.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2015-April/021669.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.