Bug 1203652 - tomcat: Duplicate Maven metadata for tomcat-jdbc
Summary: tomcat: Duplicate Maven metadata for tomcat-jdbc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ivan Afonichev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1203818 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 10:48 UTC by Mikolaj Izdebski
Modified: 2016-02-04 12:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-04 12:30:29 UTC
Type: Bug


Attachments (Terms of Use)
Proposed patch (1.65 KB, patch)
2015-03-19 13:31 UTC, Mikolaj Izdebski
no flags Details | Diff

Description Mikolaj Izdebski 2015-03-19 10:48:01 UTC
Description of problem:
Tomcat installs duplicate metadata for tomcat-jdbc Maven artifact.

Version-Release number of selected component (if applicable):
7.0.59-3

Steps to Reproduce:
xmvn-resolve org.apache.tomcat:tomcat-jdbc

Actual results:
[WARNING] Ignoring metadata for artifact org.apache.tomcat:tomcat-jdbc:jar:SYSTEM as it has duplicate metadata
[WARNING] Ignoring metadata for artifact org.apache.tomcat:tomcat-jdbc:pom:SYSTEM as it has duplicate metadata
[ERROR] Unable to resolve artifact org.apache.tomcat:tomcat-jdbc:jar:SYSTEM

Expected results:
/usr/share/java/tomcat/tomcat-jdbc.jar

Additional info:
Regression was introduced in:

commit ce74ddbcd3beba22fb70cd2dc890efa7409bf97f
Author: Stephen Gallagher <sgallagh@redhat.com>
Date:   Tue Mar 3 14:58:21 2015 -0500

    Revert to Tomcat 7

Comment 1 Stephen Gallagher 2015-03-19 12:27:59 UTC
Is the same issue present on Fedora 21 (tomcat-7.0.59-1.fc21)?

My reversion was basically to take that exact version and then bump the epoch, so if there's a problem there, it's most likely also present on F21.

Comment 2 Mikolaj Izdebski 2015-03-19 13:28:47 UTC
(In reply to Stephen Gallagher from comment #1)
> Is the same issue present on Fedora 21 (tomcat-7.0.59-1.fc21)?

This bug is present in f22 and f21-updates. f20, f20-updates, f21 and f23 are not affected.

Comment 3 Mikolaj Izdebski 2015-03-19 13:31:50 UTC
Created attachment 1003843 [details]
Proposed patch

Comment 4 Mikolaj Izdebski 2015-03-20 05:29:31 UTC
*** Bug 1203818 has been marked as a duplicate of this bug. ***

Comment 5 Ivan Afonichev 2016-02-04 12:30:29 UTC
Patch has been submitted. 1:7.0.59-4 is in stable updates.


Note You need to log in before you can comment on or make changes to this bug.