Bug 1203660 - prior env 'Library' is missing when creating a new life-cycle environment
Summary: prior env 'Library' is missing when creating a new life-cycle environment
Keywords:
Status: CLOSED DUPLICATE of bug 1189478
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 11:27 UTC by Sachin Ghai
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-22 14:48:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
missing prior env which doesn't allow to create new life-cyle env (75.92 KB, image/png)
2015-03-19 11:27 UTC, Sachin Ghai
no flags Details
production.log (12.63 KB, text/plain)
2015-03-19 11:29 UTC, Sachin Ghai
no flags Details
missing library between quotes "" with FF36.0 (30.10 KB, image/png)
2015-03-25 05:42 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 9850 0 None None None 2016-04-22 15:33:43 UTC

Description Sachin Ghai 2015-03-19 11:27:41 UTC
Created attachment 1003808 [details]
missing prior env  which doesn't allow to create new life-cyle env

Description of problem:

when creating a new life-cycle environment, UI doesn't save the form and production.log filled with below error:


2015-03-19 07:22:20 [I] Processing by Katello::Api::V2::EnvironmentsController#create as JSON
2015-03-19 07:22:20 [I]   Parameters: {"name"=>"dev", "label"=>"dev", "prior"=>"", "organization_id"=>"1", "api_version"=>"v2", "environment"=>{"name"=>"dev", "label"=>"dev", "prior"=>""}}
2015-03-19 07:22:20 [E] ActionController::ParameterMissing: key not found: prior
/opt/rh/ruby193/root/usr/share/gems/gems/strong_parameters-0.2.1/lib/action_controller/parameters.rb:55:in `require'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.24/app/controllers/katello/api/v2/environments_controller.rb:185:in `find_prior'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:521:in `block (4 levels) in _run__2732788240006921860__process_action__1153126456876487165__callbacks'



Version-Release number of selected component (if applicable):

sat6.1 beta snap7 (Satellite-6.1.0-RHEL-7-20150317.0)


How reproducible:
always

Steps to Reproduce:
1. create new life-cycle env.
2.
3.

Actual results:
2015-03-19 07:22:20 [E] ActionController::ParameterMissing: key not found: prior

Expected results:


Additional info:

Comment 1 Sachin Ghai 2015-03-19 11:29:49 UTC
Created attachment 1003809 [details]
production.log

Comment 3 Sachin Ghai 2015-03-19 11:47:43 UTC
Looks like issue is browser specific:

reproducible with:
Firefox 35.0.1
firefox-36.0-1.fc21.x86_64

Comment 4 Sachin Ghai 2015-03-19 11:50:32 UTC
in chrome, its working fine..tested with: Version 40.0.2214.93 (64-bit)

Comment 5 Walden Raines 2015-03-20 15:21:56 UTC
Created redmine issue http://projects.theforeman.org/issues/9850 from this bug

Comment 6 Walden Raines 2015-03-20 15:49:25 UTC
I cannot reproduce this on Snap 7 with Firefox 36 given the steps above.  Please provide additional steps to reproduce.

Comment 8 Eric Helms 2015-03-22 14:48:43 UTC

*** This bug has been marked as a duplicate of bug 1189478 ***

Comment 9 Sachin Ghai 2015-03-25 05:42:39 UTC
Created attachment 1006115 [details]
missing library between quotes "" with FF36.0

Comment 10 Sachin Ghai 2015-03-25 05:43:29 UTC
This issue is still reproducible with sat6.1 beta1 snap7 compose3.


Note You need to log in before you can comment on or make changes to this bug.