Bug 12037 - Fails to set hostname after install
Summary: Fails to set hostname after install
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-09 19:31 UTC by Richard D. Payne
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-23 19:19:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard D. Payne 2000-06-09 19:31:34 UTC
NFS install using bootnet.img. During the install I gave it the IP address,
netmask, gateway and DNS address. It printed out that reverse lookup
suceeded (on VT 4 I think), however on rebooting it sets the hostname
to localhost.localdomain. A quick look in /etc/sysconfig/network shows
HOSTNAME=localhost.localdomain

However, running hostname at the shell prompt returns the correct value.

Comment 1 Richard D. Payne 2000-06-09 20:10:05 UTC
It's was on VT 3 that it printed 'reverse name lookup worked' (not 4)

Comment 2 Brock Organ 2000-06-23 22:52:44 UTC
hmmm ... I cannot reproduce this problem in test here trying both TUI and GUI
modes over NFS ...

does this also occur in beta2 ...?

Comment 3 Brock Organ 2000-06-23 23:17:03 UTC
are you trying to install onto a laptop ...?

Comment 4 Richard D. Payne 2000-06-24 14:08:12 UTC
No, this is not a laptop. I'll check if beta2 has the same problem next week.

Comment 5 Richard D. Payne 2000-06-27 19:32:48 UTC
Beta2 has the same problem. /etc/sysconfig/network still reads
localhost.localdomain.

This was a full KDE install (no upgrade etc...) via NFS. I entered the IP
address into the text portition, when the GUI starts it has the correct
IP and hostname present. However on reboot it prints:
Setting Hostname localhost.localdomain	[OK]


Comment 6 Brock Organ 2000-09-08 20:05:15 UTC
did you still have this problem with any of the later betas (pinstripe, RC-1,
etc.) ...?

Comment 7 Brock Organ 2000-09-08 20:05:48 UTC
(this problem was originally reported against the Winston beta1)

Comment 8 Richard D. Payne 2000-09-08 20:50:47 UTC
I don't know, I didn't do any testing after beta3.


Note You need to log in before you can comment on or make changes to this bug.