Bug 1203735 - [events] ...was started by null@N/A
Summary: [events] ...was started by null@N/A
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Perina
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks: 1246823
TreeView+ depends on / blocked
 
Reported: 2015-03-19 14:54 UTC by Jiri Belka
Modified: 2019-10-10 09:41 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, engine processes that were not invoked directly by a logged-in user but invoked automatically either by an event or by the time scheduler had the "null@N/A" user name assigned to them in logs. This was confusing for administrators. With this update, the user name "SYSTEM" is assigned to all processes which are not invoked directly by a logged-in user so the log messages are clearer.
Clone Of:
: 1246823 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:00:11 UTC
oVirt Team: Infra


Attachments (Terms of Use)
engine.log (1.12 MB, application/x-gzip)
2015-03-19 14:54 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 39786 master MERGED core: Fix username for commands executed from Quartz jobs Never
Red Hat Knowledge Base (Solution) 2087613 None None None Never

Description Jiri Belka 2015-03-19 14:54:02 UTC
Created attachment 1003858 [details]
engine.log

Description of problem:

quite odd event message:

Host dell-r210ii-03.rhev.lab.eng.brq.redhat.com was started by null@N/A.
                                                               ^^^^^^^^^ :)


Version-Release number of selected component (if applicable):
rhevm-backend-3.5.1-0.1.el6ev.noarch

How reproducible:
??

Steps to Reproduce:
1. ?? no idea, just appears, i was testing HA VM and fencing/PM
2.
3.

Actual results:
Host dell-r210ii-03.rhev.lab.eng.brq.redhat.com was started by null@N/A.

Expected results:
null@N/A seems nonsense

Additional info:

Comment 1 Jiri Belka 2015-03-19 14:56:26 UTC
as well...:

	
2015-Mar-19, 12:57
	
Failed to log User null@N/A out.
	
	
2015-Mar-19, 12:57
	
Failed to log User null@N/A out.
	
	
2015-Mar-19, 12:57
	
Failed to log User null@N/A out.
	
	
2015-Mar-19, 12:57
	
Failed to log User null@N/A out.

Comment 2 Oved Ourfali 2015-04-12 11:43:46 UTC
Ravi - thoughts?

Comment 3 Oved Ourfali 2015-04-13 07:04:24 UTC
Removing the needinfo, as I see Martin already fixed that.

Comment 4 Martin Tessun 2015-05-18 14:34:55 UTC
Is it possible that this issue is related to BZ 1198493

Somehow the messages look very related.

Comment 6 Jiri Belka 2015-06-23 09:40:41 UTC
ok, ovirt-engine-backend-3.6.0-0.0.master.20150519172219.git9a2e2b3.el6.noarch

inspecting Events and engine.log* doesn't show any reference to 'null@N/A', yo!

Comment 11 errata-xmlrpc 2016-03-09 21:00:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.