Bug 1203740 - live migration with attached volume peforms breaking rollback on failure
Summary: live migration with attached volume peforms breaking rollback on failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 7.0 (Kilo)
Assignee: Lee Yarwood
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 14:59 UTC by Eoghan Glynn
Modified: 2019-09-09 15:05 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 17:10:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1405294 0 None None None Never

Description Eoghan Glynn 2015-03-19 14:59:06 UTC
Description of problem:

During live migration with attached volume, nova ignores initialize connection errors and does not roll back.


Version-Release number of selected component (if applicable):

openstack-nova-2014.2.2-1.el7ost


How reproducible:

Depends on simulating a initialize_connection failure during live migration.


Steps to Reproduce:
1. Create a nova instance
2. Attach a cinder volume
3. Perform ‘nova live-migration’ to a different backend
4. Cause a failure in the ‘initialize_connection’ call to the new host
5. Wait for nova to call ‘terminate_connection’ on the connection to the original host


Actual results:

Instance remains on original host with Cinder volume attached according to Cinder but no longer mapped on the backend. This removes connectivity from storage to the host and can cause data loss.


Expected results:

A clean roll back should occur on failure.


Additional info:

What seems to be happening is that Nova is not stopping the migration when receiving an error from Cinder and ends up calling terminate_connection for the src host when it should not be.


Note You need to log in before you can comment on or make changes to this bug.