Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1203741 - [events] odd 'Done' in the end of event msg - Power Management test failed for Host $host.Done
Summary: [events] odd 'Done' in the end of event msg - Power Management test failed fo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-3.6.1
: 3.6.0
Assignee: Eli Mesika
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 15:01 UTC by Jiri Belka
Modified: 2016-04-20 01:32 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-20 01:32:15 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
engine.log (1.12 MB, application/x-gzip)
2015-03-19 15:01 UTC, Jiri Belka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 45709 0 master MERGED Engine: Hide bad 'Done' message for PM test Never
oVirt gerrit 46541 0 ovirt-engine-3.6 MERGED Engine: Hide bad 'Done' message for PM test Never
oVirt gerrit 47365 0 master MERGED core: enhance log message in case of empty reason Never
oVirt gerrit 47938 0 ovirt-engine-3.6 MERGED core: enhance log message in case of empty reason Never

Description Jiri Belka 2015-03-19 15:01:53 UTC
Created attachment 1003865 [details]
engine.log

Description of problem:

following event looks quite odd...
	
2015-Mar-19, 15:53
Power Management test failed for Host $host.com.Done
                                                ^^^^ eh?
                                                                                

Version-Release number of selected component (if applicable):
rhevm-backend-3.5.1-0.1.el6ev.noarch

How reproducible:
??

Steps to Reproduce:
1. occurred while testing pm/fencing[1]
2.
3.

Actual results:
strange 'Done' in the end of event msg

Expected results:
event msg should make sense

Additional info:
[1] https://bugzilla.redhat.com/show_bug.cgi?id=1192596#c1

Comment 1 Oved Ourfali 2015-04-12 11:41:56 UTC
Hm.... Looking at the code, the "Done" you see is part of the result of running the fencing script, so I wonder whether it is part of our code or part of the underlying fencing script on the host side.

Martin - thoughts?

Jiri - does it happen all the time? When does it happen?
If it rarely happens then I'd close it as WONTFIX.

Comment 2 Jiri Belka 2015-04-20 14:09:36 UTC
Yes it is always:

2015-Apr-20, 16:06
	
Host dell-r210ii-13.rhev.lab.eng.brq.redhat.com from cluster Default was chosen as a proxy to execute Status command on Host dell-r210ii-04.rhev.lab.eng.brq.redhat.com.
	
	
2015-Apr-20, 16:06
	
Host dell-r210ii-13.rhev.lab.eng.brq.redhat.com from cluster Default was chosen as a proxy to execute Restart command on Host dell-r210ii-04.rhev.lab.eng.brq.redhat.com.
	
	
2015-Apr-20, 16:06
	
Host slot-4.rhev.lab.eng.brq.redhat.com from data center Default was chosen as a proxy to execute Status command on Host dell-r210ii-04.rhev.lab.eng.brq.redhat.com.


> Reproducing steps:
> 
> 1) Create cluster1 with 2 hosts (host1 and host2)
> 2) Create cluster2 with 1 host (host3) in the same DC as cluster1
> 3) Block connection from host2 to PM interface of host1
> 4) Turn off host1 using its PM interface
> 5) host1 become NonResponding, PM stop operation of host1 using host2 as proxy fails due to blocked connection
> 6) PM stop operation using host3 as proxy will be skipped because host1 is already down
> 7) Engine will badly interpret result of PM stop operation: instead of "skipped, because host is already turned off", it will determine result as "skipped due to fencing policy" -> host1 will not be restarted -> HA VMs running on host1 will not be restarted on different host

Comment 3 Oved Ourfali 2015-08-11 06:50:26 UTC
(In reply to Jiri Belka from comment #2)
> Yes it is always:
> 
> 2015-Apr-20, 16:06
> 	
> Host dell-r210ii-13.rhev.lab.eng.brq.redhat.com from cluster Default was
> chosen as a proxy to execute Status command on Host
> dell-r210ii-04.rhev.lab.eng.brq.redhat.com.
> 	
> 	
> 2015-Apr-20, 16:06
> 	
> Host dell-r210ii-13.rhev.lab.eng.brq.redhat.com from cluster Default was
> chosen as a proxy to execute Restart command on Host
> dell-r210ii-04.rhev.lab.eng.brq.redhat.com.
> 	
> 	
> 2015-Apr-20, 16:06
> 	
> Host slot-4.rhev.lab.eng.brq.redhat.com from data center Default was chosen
> as a proxy to execute Status command on Host
> dell-r210ii-04.rhev.lab.eng.brq.redhat.com.
> 

Jiri, looking at your comment, there is no "Done" here.
Am I missing something?

Comment 4 Jiri Belka 2015-08-12 15:37:37 UTC
I almost was thinking - was I trolling? But, yeah, I got it on 3.5.4-1.2

2015-Aug-12, 17:11
	
Power Management test failed for Host dell-r210ii-04.rhev.lab.eng.brq.redhat.com.Done
	
9001
	
dell-r210ii-04.rhev.lab.eng.brq.redhat.com
	
Default

Steps to reproduce:
- 2 hosts
- on host 2: iptables -I OUTPUT -d $host1_ipmi -j REJECT
- check PM settings of host1, click Test and wait

Comment 5 Ori Liel 2015-09-03 08:26:37 UTC
Fixed - if message is 'Done', don't show it.

Comment 7 Oved Ourfali 2015-09-22 13:03:05 UTC
Moving back to post. 
Ori, please backport it to 3.6.

Comment 8 Jiri Belka 2015-09-30 15:40:49 UTC
'Not Specified' is not much better:

Power Management test failed for Host dell-r210ii-13.rhev.lab.eng.brq.redhat.com.Not Specified

rhevm-webadmin-portal-3.6.0-0.18.el6.noarch

Comment 9 Eli Mesika 2015-10-08 13:32:08 UTC
I was not able to reproduce with the steps provided in comment 4

Comment 10 Jiri Belka 2015-10-13 11:41:22 UTC
#8 meant that 'Done' issue is solved but as #8 states clearly, there's new 'Not Specified' issue :)

Comment 11 Eli Mesika 2015-10-13 14:29:31 UTC
(In reply to Jiri Belka from comment #10)
> #8 meant that 'Done' issue is solved but as #8 states clearly, there's new
> 'Not Specified' issue :)

What are the steps to get this ?

Comment 12 Jiri Belka 2015-10-14 13:44:56 UTC
Steps to reproduce:
- 2 hosts
(- on host 2: ipmitool -e @ -I lanplus -H $host1_ipmi power status)
- on host 2: iptables -I OUTPUT -d $host1_ipmi -j REJECT
(- on host 2: ipmitool -e @ -I lanplus -H $host1_ipmi power status # failure)
- check PM settings of host1, click Test and wait

In Edit host you will see:

Test failed: 

Search for events...

Events: message = "Power Management test failed*"

Comment 13 Oved Ourfali 2015-11-02 07:25:34 UTC
Still requires backport.

Comment 14 Jiri Belka 2015-12-03 14:37:36 UTC
ok, rhevm-webadmin-portal-3.6.1.1-0.1.el6.noarch

No 'Done' in the event message.


Note You need to log in before you can comment on or make changes to this bug.