Bug 1203756 - SELinux prevents conman from communicating with sssd
Summary: SELinux prevents conman from communicating with sssd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Simon Sekidde
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 15:42 UTC by Milos Malik
Modified: 2015-07-22 07:12 UTC (History)
7 users (show)

Fixed In Version: selinux-policy-3.7.19-263.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:12:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1375 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2015-07-20 18:07:47 UTC

Description Milos Malik 2015-03-19 15:42:05 UTC
Description of problem:
# rpm -qf /usr/share/conman/exec/ipmitool.exp
conman-0.2.7-2.el6.x86_64
#

Version-Release number of selected component (if applicable):
conman-0.2.7-2.el6.x86_64
selinux-policy-3.7.19-262.el6.noarch
selinux-policy-doc-3.7.19-262.el6.noarch
selinux-policy-minimum-3.7.19-262.el6.noarch
selinux-policy-mls-3.7.19-262.el6.noarch
selinux-policy-targeted-3.7.19-262.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. get a RHEL-6.6 machine
2. install, configure and start sssd
3. modify /etc/nsswitch.conf
# grep sss /etc/nsswitch.conf
passwd:     sss files
shadow:     sss files
group:      sss files
services:   sss files
netgroup:   sss files
#
4. service conman start
5. search for AVCs

Actual results (enforcing mode):
----
type=PATH msg=audit(03/19/2015 16:29:31.344:1420) : item=0 name=/var/lib/sss/mc/passwd inode=25543 dev=fc:03 mode=dir,755 ouid=root ogid=root rdev=00:00 obj=system_u:object_r:sssd_var_lib_t:s0 nametype=NORMAL 
type=CWD msg=audit(03/19/2015 16:29:31.344:1420) :  cwd=/ 
type=SYSCALL msg=audit(03/19/2015 16:29:31.344:1420) : arch=x86_64 syscall=open success=no exit=-13(Permission denied) a0=0x247b8f0 a1=O_RDONLY|O_CLOEXEC a2=0x7fff90180b8c a3=0x7fff90180830 items=1 ppid=26933 pid=26934 auid=root uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=160 comm=ipmitool.exp exe=/usr/bin/expect subj=unconfined_u:system_r:conman_t:s0 key=(null) 
type=AVC msg=audit(03/19/2015 16:29:31.344:1420) : avc:  denied  { search } for  pid=26934 comm=ipmitool.exp name=sss dev=vda3 ino=25543 scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:object_r:sssd_var_lib_t:s0 tclass=dir 
----

Expected results:
 * no AVCs

Comment 1 Milos Malik 2015-03-19 15:54:30 UTC
Caught in permissive mode:
----
type=PATH msg=audit(03/19/2015 16:51:18.753:1521) : item=0 name=/var/lib/sss/mc/passwd inode=540 dev=fc:03 mode=file,644 ouid=root ogid=root rdev=00:00 obj=system_u:object_r:sssd_public_t:s0 nametype=NORMAL 
type=CWD msg=audit(03/19/2015 16:51:18.753:1521) :  cwd=/ 
type=SYSCALL msg=audit(03/19/2015 16:51:18.753:1521) : arch=x86_64 syscall=open success=yes exit=3 a0=0x1fae8f0 a1=O_RDONLY|O_CLOEXEC a2=0x7fff952df64c a3=0x7fff952df2f0 items=1 ppid=11979 pid=11982 auid=root uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=160 comm=ipmitool.exp exe=/usr/bin/expect subj=unconfined_u:system_r:conman_t:s0 key=(null) 
type=AVC msg=audit(03/19/2015 16:51:18.753:1521) : avc:  denied  { open } for  pid=11982 comm=ipmitool.exp name=passwd dev=vda3 ino=540 scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:object_r:sssd_public_t:s0 tclass=file 
type=AVC msg=audit(03/19/2015 16:51:18.753:1521) : avc:  denied  { read } for  pid=11982 comm=ipmitool.exp name=passwd dev=vda3 ino=540 scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:object_r:sssd_public_t:s0 tclass=file 
type=AVC msg=audit(03/19/2015 16:51:18.753:1521) : avc:  denied  { search } for  pid=11982 comm=ipmitool.exp name=mc dev=vda3 ino=25545 scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:object_r:sssd_public_t:s0 tclass=dir 
type=AVC msg=audit(03/19/2015 16:51:18.753:1521) : avc:  denied  { search } for  pid=11982 comm=ipmitool.exp name=sss dev=vda3 ino=25543 scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:object_r:sssd_var_lib_t:s0 tclass=dir 
----
type=SYSCALL msg=audit(03/19/2015 16:51:18.757:1522) : arch=x86_64 syscall=fstat success=yes exit=0 a0=0x3 a1=0x7fff952df5b0 a2=0x7fff952df5b0 a3=0x7fff952df320 items=0 ppid=11979 pid=11982 auid=root uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=160 comm=ipmitool.exp exe=/usr/bin/expect subj=unconfined_u:system_r:conman_t:s0 key=(null) 
type=AVC msg=audit(03/19/2015 16:51:18.757:1522) : avc:  denied  { getattr } for  pid=11982 comm=ipmitool.exp path=/var/lib/sss/mc/passwd dev=vda3 ino=540 scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:object_r:sssd_public_t:s0 tclass=file 
----
type=PATH msg=audit(03/19/2015 16:51:18.757:1523) : item=0 name=(null) inode=370 dev=fc:03 mode=socket,666 ouid=root ogid=root rdev=00:00 obj=system_u:object_r:sssd_var_lib_t:s0 nametype=NORMAL 
type=SOCKADDR msg=audit(03/19/2015 16:51:18.757:1523) : saddr=local /var/lib/sss/pipes/nss 
type=SYSCALL msg=audit(03/19/2015 16:51:18.757:1523) : arch=x86_64 syscall=connect success=yes exit=0 a0=0x4 a1=0x7fff952df610 a2=0x6e a3=0x7fff952df2a0 items=1 ppid=11979 pid=11982 auid=root uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=160 comm=ipmitool.exp exe=/usr/bin/expect subj=unconfined_u:system_r:conman_t:s0 key=(null) 
type=AVC msg=audit(03/19/2015 16:51:18.757:1523) : avc:  denied  { connectto } for  pid=11982 comm=ipmitool.exp path=/var/lib/sss/pipes/nss scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:system_r:sssd_t:s0 tclass=unix_stream_socket 
type=AVC msg=audit(03/19/2015 16:51:18.757:1523) : avc:  denied  { write } for  pid=11982 comm=ipmitool.exp name=nss dev=vda3 ino=370 scontext=unconfined_u:system_r:conman_t:s0 tcontext=system_u:object_r:sssd_var_lib_t:s0 tclass=sock_file 
----

Comment 5 errata-xmlrpc 2015-07-22 07:12:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1375.html


Note You need to log in before you can comment on or make changes to this bug.