This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 120378 - policy loads/writes wrong policy version on install
policy loads/writes wrong policy version on install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 02:01 EDT by Kaj J. Niemi
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 08:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2004-04-08 02:01:08 EDT
Description of problem:
Version 15 is being loaded while version 16 is what is getting
installed from the RPM, isn't this wrong?

% rpm -Uvh policy-*
WARNING: Multiple same specifications for /usr/local/lost\+found(/.*)?.
WARNING: Multiple same specifications for /usr/local/\.journal.
Preparing...               
########################################### [100%]
   1:policy                
########################################### [ 50%]
   2:policy-sources        
########################################### [100%]
make: Entering directory `/etc/security/selinux/src/policy'
mkdir -p /etc/security/selinux
/usr/bin/checkpolicy -c -o /etc/security/selinux/policy.15
/etc/security/selinux/src/policy.conf
/usr/bin/checkpolicy:  loading policy configuration from
/etc/security/selinux/src/policy.conf
security:  4 users, 6 roles, 1196 types, 1 bools
security:  30 classes, 276024 rules
/usr/bin/checkpolicy:  policy configuration loaded
/usr/bin/checkpolicy:  writing binary representation (version 15) to
/etc/security/selinux/policy.15
warning: discarding booleans and conditional rules
/usr/sbin/load_policy /etc/security/selinux/policy.`cat
/selinux/policyvers`
touch tmp/load
make: Leaving directory `/etc/security/selinux/src/policy'

# rpm -qi policy policy-sources
policy-1.10.1-2
policy-sources-1.10.1-2

# rpm -ql policy
/etc/security/default_contexts
/etc/security/default_type
/etc/security/failsafe_context
/etc/security/initrc_context
/etc/security/selinux
/etc/security/selinux/file_contexts
/etc/security/selinux/policy.16

# rpm -qf /etc/security/selinux/policy.15
file /etc/security/selinux/policy.15 is not owned by any package

# cat /selinux/policyvers
15

How reproducible:
Always
Comment 1 Michael Young 2004-04-08 04:51:29 EDT
Version 15 seems to be set in the
/etc/security/selinux/src/policy/Makefile
PREPOLICYVER=policy.15
Comment 2 Daniel Walsh 2004-04-08 08:42:15 EDT
Policy.15 is there to support older kernels.

Note You need to log in before you can comment on or make changes to this bug.