Bug 1203810 - audit spams the journal
Summary: audit spams the journal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audit
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 17:40 UTC by Matthias Clasen
Modified: 2015-05-04 15:24 UTC (History)
1 user (show)

Fixed In Version: audit-2.4.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-04 15:24:12 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Matthias Clasen 2015-03-19 17:40:32 UTC
I see this in my journal, quite a bit, recently:

Mar 19 09:42:37 localhost audispd[803]: queue is full - dropping event
Mar 19 09:42:37 localhost audispd[803]: queue is full - dropping event
Mar 19 09:42:37 localhost audispd[803]: queue is full - dropping event
Mar 19 09:42:37 localhost audispd[803]: queue is full - dropping event
Mar 19 09:42:37 localhost audispd[803]: queue is full - dropping event
Mar 19 09:42:37 localhost audispd[803]: queue is full - dropping event

This a) should not be happening and b) if you get enough to clog up your own queue, is it really a good idea to clog up the journal as well ?

Comment 1 Steve Grubb 2015-03-31 13:14:12 UTC
The problem is that the system is being flooded by events, which is not the normally operating condition of the system. This can happen, for example, when selinux policy changes or a major upgrade of a program causes a lot of AVC's before policy is updated. The solution is to find the root cause of the flood of events and fix that by example, relabling the disk.

aureport --start today --summary --event -i

would help to figure out what kind of event is flooding the system.

Comment 2 Steve Grubb 2015-04-01 01:31:04 UTC
Also, in double checking the code...it looks like this message is not limited like the other warnings. They normally stop after about 10 messages. I'll add that logic to audispd so that its consistent with other parts of the audit system.

Comment 3 Steve Grubb 2015-04-08 21:18:52 UTC
Limit added in upstream commit 1070.

Comment 4 Fedora Update System 2015-04-30 19:12:04 UTC
audit-2.4.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audit-2.4.2-1.fc22

Comment 5 Fedora Update System 2015-05-01 16:54:05 UTC
Package audit-2.4.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audit-2.4.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7366/audit-2.4.2-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-05-04 15:24:12 UTC
audit-2.4.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.