Bug 1203834 - [abrt] gnome-software: g_type_check_instance(): gnome-software killed by SIGSEGV
Summary: [abrt] gnome-software: g_type_check_instance(): gnome-software killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ed26967f3e2f9166781bb138249...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 18:31 UTC by 123
Modified: 2015-10-09 06:14 UTC (History)
2 users (show)

Fixed In Version: gnome-software-3.18.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-09 06:14:24 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (45.08 KB, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: cgroup (190 bytes, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: core_backtrace (24.62 KB, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: dso_list (12.49 KB, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: environ (916 bytes, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: limits (1.29 KB, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: maps (62.52 KB, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: open_fds (2.66 KB, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: proc_pid_status (962 bytes, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details
File: var_log_messages (6.14 KB, text/plain)
2015-03-19 18:31 UTC, 123
no flags Details

Description 123 2015-03-19 18:31:42 UTC
Description of problem:
I install some programms just.

Version-Release number of selected component:
gnome-software-3.15.91-1.fc22

Additional info:
reporter:       libreport-2.4.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: g_type_check_instance
executable:     /usr/bin/gnome-software
kernel:         4.0.0-0.rc4.git0.1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_type_check_instance at gtype.c:4134
 #1 g_signal_handlers_disconnect_matched at gsignal.c:2858
 #2 gs_app_row_destroy at gs-app-row.c:366
 #7 gtk_widget_dispose at gtkwidget.c:11962
 #9 gtk_container_remove at gtkcontainer.c:1737
 #10 gtk_list_box_forall_internal at gtklistbox.c:2360
 #11 gs_shell_installed_load at gs-shell-installed.c:237
 #12 gs_shell_installed_reload at gs-shell-installed.c:261
 #13 gs_shell_updates_changed_cb at gs-shell.c:505
 #14 _g_closure_invoke_va at gclosure.c:831

Comment 1 123 2015-03-19 18:31:45 UTC
Created attachment 1004002 [details]
File: backtrace

Comment 2 123 2015-03-19 18:31:46 UTC
Created attachment 1004003 [details]
File: cgroup

Comment 3 123 2015-03-19 18:31:47 UTC
Created attachment 1004004 [details]
File: core_backtrace

Comment 4 123 2015-03-19 18:31:49 UTC
Created attachment 1004006 [details]
File: dso_list

Comment 5 123 2015-03-19 18:31:50 UTC
Created attachment 1004008 [details]
File: environ

Comment 6 123 2015-03-19 18:31:51 UTC
Created attachment 1004010 [details]
File: limits

Comment 7 123 2015-03-19 18:31:53 UTC
Created attachment 1004012 [details]
File: maps

Comment 8 123 2015-03-19 18:31:54 UTC
Created attachment 1004014 [details]
File: open_fds

Comment 9 123 2015-03-19 18:31:55 UTC
Created attachment 1004016 [details]
File: proc_pid_status

Comment 10 123 2015-03-19 18:31:56 UTC
Created attachment 1004017 [details]
File: var_log_messages

Comment 11 Kalev Lember 2015-03-19 22:19:54 UTC
Looks like a GsApp ref / unref mismatch somewhere. Do you have a way to reproduce this, by any chance?

Comment 12 123 2015-03-20 11:52:19 UTC
I'm so sorrty but I can't tell precisely about this bug because I have some other bugs now. If i reproduce this that need i to do then?

Comment 13 Kalev Lember 2015-03-20 11:58:24 UTC
If you find a way to reproduce it, please let me know what steps you did to get it to crash and I'll see if I can figure out the cause then.

Comment 14 Fedora Update System 2015-10-07 13:21:12 UTC
gnome-software-3.18.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-88c71c30c0

Comment 15 Fedora Update System 2015-10-07 16:27:17 UTC
gnome-software-3.18.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-software'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-88c71c30c0

Comment 16 Fedora Update System 2015-10-09 06:14:04 UTC
gnome-software-3.18.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.