Bug 120386 - need to allow time to be set before attempting registration
Summary: need to allow time to be set before attempting registration
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike McCune
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 145467
TreeView+ depends on / blocked
 
Reported: 2004-04-08 12:03 UTC by Chris Runge
Modified: 2009-03-24 17:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 17:53:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Runge 2004-04-08 12:03:11 UTC
Description of problem:

Since registration will fail on systems whose clocks are out of sync
it is important that the Kickstart script allow for an rdate/ntpdate
prior to activation in the %post section.

With manual Kickstarts this isn't a problem. However, when using
Kickstarts from the Provisioning module all registration actions are
performed before any user-added %post entries, making this no longer
an option. Subsequently registrations are failing on some client
systems when they Kickstart.

One idea might be to present an option to have the Satellite Server
set the time on the clients during the Kickstart process and before
installation. Short-term, however, there needs to be a way to insert
the rdate/ntpdate command ahead of the rhnreg_ks command.

Version-Release number of selected component (if applicable):

RHN Satellite 3.2-10 w/ Provisioning

Comment 1 Robin Norwood 2006-10-17 15:43:19 UTC
mass re-assign to mmccune


Note You need to log in before you can comment on or make changes to this bug.