Bug 1203896 - slang.h contains duplication definition of SLrline_get_update_client_data
Summary: slang.h contains duplication definition of SLrline_get_update_client_data
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: slang
Version: 22
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 21:49 UTC by Alexander Duyck
Modified: 2015-09-21 03:31 UTC (History)
2 users (show)

Fixed In Version: slang-2.3.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-29 04:31:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Alexander Duyck 2015-03-19 21:49:40 UTC
Description of problem:
When I was trying to compile perf I was getting a build error due to a duplicate declaration of SLrline_get_update_client_data.  In order to get it to work correctly.

Version-Release number of selected component (if applicable):
Installed Packages
Name        : slang
Arch        : x86_64
Version     : 2.3.0
Release     : 1.fc22

Name        : slang-devel
Arch        : x86_64
Version     : 2.3.0
Release     : 1.fc22
Size        : 353 k


How reproducible:
Always

Steps to Reproduce:
1. Install slang and slang-devel
2. Attempt to build something that includes /usr/include/slang/slang.h
3. Build error should be immediate

Actual results:
The following build error
In file included from /usr/src/kernels/net-next/tools/perf/util/include/../../ui/libslang.h:12:0,
                 from /usr/src/kernels/net-next/tools/perf/util/include/../../ui/keysyms.h:4,
                 from /usr/src/kernels/net-next/tools/perf/util/include/../hist.h:305,
                 from /usr/src/kernels/net-next/tools/perf/util/include/../sort.h:23,
                 from ui/gtk/hists.c:4:
/usr/include/slang/slang.h:1634:15: error: redundant redeclaration of ‘SLrline_get_update_client_data’ [-Werror=redundant-decls]
 SL_EXTERN int SLrline_get_update_client_data (SLrline_Type *, VOID_STAR *);
               ^
  CC       fs/fs.o
/usr/include/slang/slang.h:1627:15: note: previous declaration of ‘SLrline_get_update_client_data’ was here
 SL_EXTERN int SLrline_get_update_client_data (SLrline_Type *, VOID_STAR *);
               ^
In file included from /usr/src/kernels/net-next/tools/perf/util/include/../../ui/libslang.h:12:0,
                 from /usr/src/kernels/net-next/tools/perf/util/include/../../ui/keysyms.h:4,
                 from /usr/src/kernels/net-next/tools/perf/util/include/../hist.h:305,
                 from /usr/src/kernels/net-next/tools/perf/util/include/../sort.h:23,
                 from ui/gtk/browser.c:4:
/usr/include/slang/slang.h:1634:15: error: redundant redeclaration of ‘SLrline_get_update_client_data’ [-Werror=redundant-decls]
 SL_EXTERN int SLrline_get_update_client_data (SLrline_Type *, VOID_STAR *);
               ^
/usr/include/slang/slang.h:1627:15: note: previous declaration of ‘SLrline_get_update_client_data’ was here
 SL_EXTERN int SLrline_get_update_client_data (SLrline_Type *, VOID_STAR *);
               ^


Expected results:
No build error

Additional info:
It looks like a patch may have already been submitted based on the one I found at:
http://lists.jedsoft.org/lists/slang-users/2015/0000000.html

Comment 1 Miroslav Lichvar 2015-03-20 07:08:38 UTC
Ok, I'll include the patch in the Fedora package. I thought this was just a cosmetic issue, not breaking anything.

Comment 2 Fedora Update System 2015-03-20 07:54:46 UTC
slang-2.3.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/slang-2.3.0-2.fc22

Comment 3 Fedora Update System 2015-03-21 05:02:24 UTC
Package slang-2.3.0-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing slang-2.3.0-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4343/slang-2.3.0-2.fc22
then log in and leave karma (feedback).

Comment 4 Alexander Duyck 2015-03-25 17:24:42 UTC
Issue appears to be resolve in my environment with latest slang/slang-devel packages.

Comment 5 Fedora Update System 2015-03-29 04:31:41 UTC
slang-2.3.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.