Bug 1203951 - [aarch64] ghci not enabled
Summary: [aarch64] ghci not enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghc
Version: rawhide
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-20 03:04 UTC by Jens Petersen
Modified: 2015-05-08 07:34 UTC (History)
3 users (show)

Fixed In Version: ghc-7.8.4-44.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-08 07:34:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1195231 None None None Never

Internal Links: 1195231

Description Jens Petersen 2015-03-20 03:04:43 UTC
Description of problem:
Due to build problems probably related to dynamic linking
(eg dynamic "ghc-pkg --version" not outputting from subprocess)
ghc-7.8 (and 7.10) are built currently with DYNAMIC_GHC_PROGRAMS=NO
on aarch64.  It is possible that ld.gold might help but
apparently it is not mature/full-featured yet.

This results in no ghci on aarch64.

Upstream bug is https://ghc.haskell.org/trac/ghc/ticket/9673

Version-Release number of selected component (if applicable):
ghc-7.8.4 (patched)
(ghc-7.10.1 and current ghc-7.11)

How reproducible:
100%

Comment 1 Fedora Update System 2015-04-01 05:57:50 UTC
ghc-srpm-macros-1.4.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/ghc-srpm-macros-1.4.1-1.fc22

Comment 2 Fedora Update System 2015-04-02 18:59:52 UTC
Package ghc-srpm-macros-1.4.1-1.fc22, ghc-rpm-macros-1.4.14-1.fc22, ghc-7.8.4-43.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghc-srpm-macros-1.4.1-1.fc22 ghc-rpm-macros-1.4.14-1.fc22 ghc-7.8.4-43.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5414/ghc-7.8.4-43.fc22,ghc-srpm-macros-1.4.1-1.fc22,ghc-rpm-macros-1.4.14-1.fc22
then log in and leave karma (feedback).

Comment 3 Jens Petersen 2015-04-03 02:06:26 UTC
I tried building with ld.gold (note gold is not enabled by default for
Fedora aarch64 yet since apparently it is not complete), but it didn't seem
to help with the dynamic "ghc-pkg --version" not outputting, etc.

Comment 4 Jens Petersen 2015-04-27 07:06:51 UTC
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2975215
scratch build enabling ghci

(actually it was unrelated to the dynamic linking of ghc programs)

Comment 5 Jens Petersen 2015-04-28 04:35:23 UTC
This should be fixed in ghc-7.8.4-44.fc23.

Comment 6 Jens Petersen 2015-05-01 02:36:52 UTC
Note however that /usr/bin/ghci crashes while trying to load libHSghc-prim.so,
but Template Haskell seems to compile okay.

Comment 7 Fedora Update System 2015-05-01 10:30:00 UTC
ghc-srpm-macros-1.4.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/ghc-srpm-macros-1.4.2-1.fc22

Comment 8 Fedora Update System 2015-05-02 18:05:08 UTC
Package ghc-7.8.4-44.fc22, ghc-srpm-macros-1.4.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghc-7.8.4-44.fc22 ghc-srpm-macros-1.4.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7395/ghc-7.8.4-44.fc22,ghc-srpm-macros-1.4.2-1.fc22
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-05-08 07:34:15 UTC
ghc-7.8.4-44.fc22, ghc-srpm-macros-1.4.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.