Bug 1204006 - libvirt still try to setting vcpus for offline domain
Summary: libvirt still try to setting vcpus for offline domain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-20 06:59 UTC by Luyao Huang
Modified: 2015-11-19 06:24 UTC (History)
5 users (show)

Fixed In Version: libvirt-1.2.16-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:24:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2015-03-20 06:59:40 UTC
Description of problem:
libvirt still try to setting vcpus for offline domain

Version-Release number of selected component (if applicable):
libvirt-1.2.8-16.el7_1.1.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1.prepare a offline vm:
# virsh list --all

 Id    Name                           State
----------------------------------------------------
 -     test4                          shut off

2.
# virsh setvcpus test3 4
error: Failed to create controller cpu for group: No such file or directory

Actual results:
libvirt still try to setting vcpus for offline domain

Expected results:

# virsh setvcpus crashvm 4
error: Requested operation is not valid: domain is not running

Additional info:

test with libvirt-1.2.8-13.el7.x86_64:

# virsh setvcpus crashvm 4
error: Requested operation is not valid: domain is not running

Comment 1 Luyao Huang 2015-03-20 07:08:13 UTC
patch post upstream:

https://www.redhat.com/archives/libvir-list/2015-March/msg01042.html

Comment 2 Pavel Hrdina 2015-03-20 15:05:48 UTC
Upstream patch v2 posted:

https://www.redhat.com/archives/libvir-list/2015-March/msg01072.html

Comment 3 Pavel Hrdina 2015-05-05 12:56:20 UTC
Upstream commit:

commit 5bb0666545e47752c5922396ce5522a49c6c78e2
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Tue Mar 24 18:14:12 2015 +0100

    qemu: move virDomainLiveConfigHelperMethod right after BeginJob
    
    We should call virDomainLiveConfigHelperMethod ASAP because this
    function transfers VIR_DOMAIN_AFFECT_CURRENT to VIR_DOMAIN_AFFECT_LIVE
    or VIR_DOMAIN_AFFECT_CONFIG.  All other additional checks for those two
    flags should consider that the user give us VIR_DOMAIN_AFFECT_CURRENT.
    
    Remove the unnecessary check whether the domain is live in case of
    VIR_DOMAIN_VCPU_GUEST because this check is done by
    virDomainLiveConfigHelperMethod.
    
    Signed-off-by: Pavel Hrdina <phrdina@redhat.com>

v1.2.13-277-g5bb0666

Comment 5 Luyao Huang 2015-07-30 03:04:08 UTC
Verify this bug with libvirt-1.2.17-2.el7.x86_64:

1. prepare a offline guest:

# virsh domstate r6
shut off

2. do setvcpus with no option:

# virsh setvcpus r6 5
error: Requested operation is not valid: domain is not running

# virsh setvcpus r6 5 --live
error: Requested operation is not valid: domain is not running

Comment 7 errata-xmlrpc 2015-11-19 06:24:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.