Bug 1204125 - Issue with service dialog import/export when using dynamic drop-downs
Summary: Issue with service dialog import/export when using dynamic drop-downs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.4.0
Assignee: Shveta
QA Contact: Shveta
URL:
Whiteboard:
Depends On:
Blocks: 1210798
TreeView+ depends on / blocked
 
Reported: 2015-03-20 12:49 UTC by Marco Berube
Modified: 2015-06-16 12:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1210798 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:54:20 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Entry point data (63.77 KB, image/png)
2015-04-21 22:59 UTC, Shveta
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 0 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Marco Berube 2015-03-20 12:49:43 UTC
Description of problem:

Service dialogs with dynamic drop-down cannot be exported/imported successfully.  All dynamic drop-down links to the automate model are lost after the import is completed.  

The admin user but re-enter all dynamic drop down links manually.


Version-Release number of selected component (if applicable):


How reproducible:

Very easily.


Steps to Reproduce:
1.  Create a service dialog with multiple dynamic drop-downs
2.  Export this dialog
3.  Import this dialog

Actual results:

Dynamic drop down links will be lost.  


Expected results:

Dynamic drop down links should still be pointing to the same automate model location.


Additional info:

Comment 2 Greg McCullough 2015-03-20 14:58:26 UTC
Erik - Looks like we are not capturing the resource_action along with these fields.

Comment 3 CFME Bot 2015-04-09 20:40:58 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/154de3f79447d7fd6ff890c8e6f0fa363f8488d3

commit 154de3f79447d7fd6ff890c8e6f0fa363f8488d3
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Tue Mar 31 00:52:05 2015 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Tue Mar 31 00:52:05 2015 -0700

    Serialize ResourceAction when exporting a DialogField
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1204125

 vmdb/app/models/dialog_field_serializer.rb         |  8 ++-
 vmdb/app/models/resource_action_serializer.rb      |  7 ++
 vmdb/spec/models/dialog_field_serializer_spec.rb   | 74 ++++++++++++----------
 .../spec/models/resource_action_serializer_spec.rb | 36 +++++++++++
 4 files changed, 91 insertions(+), 34 deletions(-)
 create mode 100644 vmdb/app/models/resource_action_serializer.rb
 create mode 100644 vmdb/spec/models/resource_action_serializer_spec.rb

Comment 4 CFME Bot 2015-04-09 20:41:02 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c17101e7315a1c4456301371d7e61d43114fd9ea

commit c17101e7315a1c4456301371d7e61d43114fd9ea
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Tue Mar 31 00:52:25 2015 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Tue Mar 31 00:52:25 2015 -0700

    When importing DialogField, create a new resource action if it exists
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1204125

 vmdb/app/models/dialog_field_importer.rb       |  5 ++++-
 vmdb/spec/models/dialog_field_importer_spec.rb | 20 +++++++++++++++++---
 2 files changed, 21 insertions(+), 4 deletions(-)

Comment 5 CFME Bot 2015-04-09 20:41:06 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ec80e5d7bcd9de01f681f6253eda825d17facfce

commit ec80e5d7bcd9de01f681f6253eda825d17facfce
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Tue Mar 31 08:09:58 2015 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Thu Apr 2 01:17:22 2015 -0700

    Fix rubocop issues and failing spec
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1204125

 vmdb/spec/models/dialog_field_importer_spec.rb      |  8 ++++----
 vmdb/spec/models/resource_action_serializer_spec.rb | 14 +++++++-------
 2 files changed, 11 insertions(+), 11 deletions(-)

Comment 6 CFME Bot 2015-04-10 13:46:04 UTC
New commit detected on cfme/5.3.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=69e3c2b474baf428d08001bf316fd704939d80e0

commit 69e3c2b474baf428d08001bf316fd704939d80e0
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Tue Mar 31 00:52:05 2015 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Thu Apr 9 14:09:12 2015 -0700

    Serialize ResourceAction when exporting a DialogField
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1204125
    
    Conflicts:
    	vmdb/spec/models/dialog_field_serializer_spec.rb

 vmdb/app/models/dialog_field_serializer.rb         |  8 ++-
 vmdb/app/models/resource_action_serializer.rb      |  7 +++
 vmdb/spec/models/dialog_field_serializer_spec.rb   | 71 +++++++++++++---------
 .../spec/models/resource_action_serializer_spec.rb | 36 +++++++++++
 4 files changed, 91 insertions(+), 31 deletions(-)
 create mode 100644 vmdb/app/models/resource_action_serializer.rb
 create mode 100644 vmdb/spec/models/resource_action_serializer_spec.rb

Comment 7 CFME Bot 2015-04-10 13:46:08 UTC
New commit detected on cfme/5.3.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=d67918c2c34d413f48d4e97529638930b90500b3

commit d67918c2c34d413f48d4e97529638930b90500b3
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Tue Mar 31 00:52:25 2015 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Thu Apr 9 14:09:23 2015 -0700

    When importing DialogField, create a new resource action if it exists
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1204125

 vmdb/app/models/dialog_field_importer.rb       |  5 ++++-
 vmdb/spec/models/dialog_field_importer_spec.rb | 20 +++++++++++++++++---
 2 files changed, 21 insertions(+), 4 deletions(-)

Comment 8 CFME Bot 2015-04-10 13:46:12 UTC
New commit detected on cfme/5.3.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7d6b5e88e8deb818a880f8ad826dc983813dd61d

commit 7d6b5e88e8deb818a880f8ad826dc983813dd61d
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Tue Mar 31 08:09:58 2015 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Thu Apr 9 14:09:30 2015 -0700

    Fix rubocop issues and failing spec
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1204125

 vmdb/spec/models/dialog_field_importer_spec.rb      |  8 ++++----
 vmdb/spec/models/resource_action_serializer_spec.rb | 14 +++++++-------
 2 files changed, 11 insertions(+), 11 deletions(-)

Comment 9 CFME Bot 2015-04-10 13:46:16 UTC
New commit detected on cfme/5.3.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ce6df222c83872c123e8f7cd7c3ee1299af9bfa7

commit ce6df222c83872c123e8f7cd7c3ee1299af9bfa7
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Thu Apr 9 14:29:22 2015 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Thu Apr 9 14:29:22 2015 -0700

    Fix specs to reflect 5.3.z database settings
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1204125

 vmdb/spec/models/dialog_field_importer_spec.rb   | 14 +++++++-------
 vmdb/spec/models/dialog_field_serializer_spec.rb |  7 ++-----
 2 files changed, 9 insertions(+), 12 deletions(-)

Comment 11 Shveta 2015-04-20 21:54:33 UTC
Not fixed in 5.4.0.0.19.20150410165622_ad23806 .
Will check in next build

Comment 12 Shveta 2015-04-21 22:08:52 UTC
dynamic drop-down removed from service dialog in build 5.4.0.0.22.20150420163946_26004d1 ??

Comment 13 Greg McCullough 2015-04-21 22:43:44 UTC
Hi Shveta - With PR #2356 (https://github.com/ManageIQ/manageiq/pull/2356) dynamic drop-downs are now normal drop-down list fields with the dynamic flag set.  Otherwise it is exactly the same as it was before.

Comment 14 Shveta 2015-04-21 22:59:19 UTC
Created attachment 1017164 [details]
Entry point data

Verified in 5.4.0.0.22.20150420163946_26004d1

Comment 16 errata-xmlrpc 2015-06-16 12:54:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.