This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 120413 - Bug in udev uninstall script
Bug in udev uninstall script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 11:12 EDT by Albert Strasheim
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 10:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2004-04-08 11:12:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When the udev RPM is uninstalled, an error message is displayed. It
looks like a bug in the uninstall scripts:

/var/tmp/rpm-tmp.64958: line 1: [: missing `]'

Version-Release number of selected component (if applicable):
udev-023-1

How reproducible:
Always

Steps to Reproduce:
1. Uninstall udev

Actual Results:  Uninstall script encounters an error

Expected Results:  Uninstall script should work without an error
message being displayed

Additional info:
Comment 1 Forrest 2004-04-12 16:22:14 EDT
For what it is worth, it is a space in the preuninstall scriptlet:

if [ $1 = 0 -a -f /etc/rc.d/init.d/udev];then

should be:

if [ $1 = 0 -a -f /etc/rc.d/init.d/udev ];then
Comment 2 Harald Hoyer 2004-04-21 10:03:48 EDT
fixed

Note You need to log in before you can comment on or make changes to this bug.