Bug 120414 - Programs requiring root password don't work after it's entered from user gnome
Programs requiring root password don't work after it's entered from user gnome
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 11:38 EDT by Michael J. Kofler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 23:44:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Kofler 2004-04-08 11:38:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
With previous RH versions, clicking on a program that required root
permissions to run (up2date, for example, but the problem is occuring
with all such programs) brought up a Query window asking for the root
password. Once given, the program would load with root permissions. 
Now, the Query window appears, password is given, and then nothing
happens. Invoking the program from ternimal also causes Query window
to ask for root password (like expected), but again program fails to
load and terminal provides no additional information- terminal returns
to new command line as soon as enter is hit to submit root password.
From root command line terminal (via su), invoking program works as
expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. As user, click program requiring root permissions
2. Enter correct root password in query window
3. Brood.
    

Actual Results:  Programs failed to load after asking for root password.

Expected Results:  Programs load as in previous RH versions

Additional info:
Comment 1 Michael J. Kofler 2004-06-14 22:56:49 EDT
The query window when attempting to run up2date seems to be asking for
the user password (Asks "Password for mkofler") instead of the root
password as expected. Entering the user password causes the window to
close, and gives the error "Could not set exec context to
mkofler:sysadm_r:rpm_t.". 

Comment 2 Michael J. Kofler 2004-06-14 23:44:37 EDT
Fixed after latest update

Note You need to log in before you can comment on or make changes to this bug.