Bug 1204175 - cronie-anacron-1.4.4-14.el6.x86_64 doesn't like its own /etc/anacrontab syntax
Summary: cronie-anacron-1.4.4-14.el6.x86_64 doesn't like its own /etc/anacrontab syntax
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-20 14:16 UTC by John T. Rose
Modified: 2015-03-30 08:09 UTC (History)
6 users (show)

Fixed In Version: cronie-1.4.4-15.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-30 08:09:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0754 normal SHIPPED_LIVE cronie bug fix update 2015-03-30 12:09:01 UTC

Description John T. Rose 2015-03-20 14:16:34 UTC
Description of problem:

After updating from cronie-anacron-1.4.4-12.el6.x86_64 to cronie-anacron-1.4.4-14.el6.x86_64 anacron is unhappy with /etc/anacrontab.

# rpm -q cronie-anacron
cronie-anacron-1.4.4-12.el6.x86_64
# rpm -V cronie-anacron
# anacron -T
#

# rpm -q cronie-anacron
cronie-anacron-1.4.4-14.el6.x86_64
# rpm -V cronie-anacron
# anacron -T
anacron: Invalid syntax in /etc/anacrontab on line 5 - skipping this line
anacron: Invalid syntax in /etc/anacrontab on line 6 - skipping this line
anacron: Invalid syntax in /etc/anacrontab on line 7 - skipping this line

It seems unhappy about the stock variable declarations

SHELL=/bin/sh
PATH=/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=root

Version-Release number of selected component (if applicable):

cronie-anacron-1.4.4-14.el6.x86_64

How reproducible:

Always so far as I know now.

Steps to Reproduce:
1. Upgrade cronie-anacron to version 1.4.4-14
2. Run anacron -T or most anything else
3. See invalid syntax messages

Actual results:


Expected results:


Additional info:

Comment 3 Tomas Mraz 2015-03-20 14:53:40 UTC
This is serious regression and I am sorry for that.

Comment 17 errata-xmlrpc 2015-03-30 08:09:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0754.html


Note You need to log in before you can comment on or make changes to this bug.