Bug 1204195 - fix doc to describe actual uri format in nslcd.conf
Summary: fix doc to describe actual uri format in nslcd.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nss-pam-ldapd
Version: 6.7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Ondrej Moriš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-20 14:58 UTC by Dalibor Pospíšil
Modified: 2016-05-10 19:45 UTC (History)
5 users (show)

Fixed In Version: nss-pam-ldapd-0.7.5-31.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1204202 (view as bug list)
Environment:
Last Closed: 2016-05-10 19:45:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0758 normal SHIPPED_LIVE nss-pam-ldapd bug fix update 2016-05-10 22:32:39 UTC

Description Dalibor Pospíšil 2015-03-20 14:58:40 UTC
Description of problem:
It should be correctly stated in man page of nslcd.conf that multiple URIs can be set by using more uri lines or more URIs defined on one uri line.

Version-Release number of selected component (if applicable):
nss-pam-ldapd-0.7.5-20.el6_6.3

How reproducible:
100%

Steps to Reproduce:
1. man nslcd.conf
2.
3.

Actual results:
       uri URI
              Specifies the LDAP URI of the server to connect to.  The URI scheme may be ldap, ldapi or ldaps, specifying LDAP over TCP, ICP or SSL respectively (if supported by the LDAP library).   Alternatively,
              the value DNS may be used to try to lookup the server using DNS SRV records. By default the current domain is used but another domain can be queried by using the DNS:DOMAIN syntax.

              When using the ldapi scheme, %2f should be used to escape slashes (e.g. ldapi://%2fvar%2frun%2fslapd%2fldapi/), although most of the time this should not be needed.

              This option may be specified multiple times. Normally, only the first server will be used with the following servers as fall-back (see bind_timelimit below).

              If LDAP lookups are used for host name resolution, any host names should be specified as an IP address or name that can be resolved without using LDAP.


Expected results:
       uri URI ...
              Specifies the LDAP URI of the server to connect to.  The URI scheme may be ldap, ldapi or ldaps, specifying LDAP over TCP, ICP or SSL respectively (if supported by the LDAP library).   Alternatively,
              the value DNS may be used to try to lookup the server using DNS SRV records. By default the current domain is used but another domain can be queried by using the DNS:DOMAIN syntax.

              When using the ldapi scheme, %2f should be used to escape slashes (e.g. ldapi://%2fvar%2frun%2fslapd%2fldapi/), although most of the time this should not be needed.

              This option may be specified multiple times and/or with more URIs on the line, separated by space. Normally, only the first server will be used with the following servers as fall-back (see bind_timelimit below).

              If LDAP lookups are used for host name resolution, any host names should be specified as an IP address or name that can be resolved without using LDAP.

Comment 1 Arthur de Jong 2015-03-20 19:37:06 UTC
Thanks for your patch. I will probably include your text in the next (upstream) release of nss-pam-ldapd. However, the option to have space-separated URIs was mostly added as a compatibility hack for nss_ldap so was more or less an explicitly undocumented feature.

Comment 2 Jakub Hrozek 2015-10-06 11:33:06 UTC
Patch was accepted upstream as 95d621ef8cb5d4969e58262eef34b0c0fde9ae6e

Comment 10 errata-xmlrpc 2016-05-10 19:45:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0758.html


Note You need to log in before you can comment on or make changes to this bug.