Bug 1204244 - [fix available] libreoffice-base edit window opened in different group
Summary: [fix available] libreoffice-base edit window opened in different group
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On: 1196704 1205091
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-20 16:50 UTC by Marek Stana
Modified: 2015-11-23 16:14 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-11-23 16:14:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2197 normal SHIPPED_LIVE libreoffice bug fix and enhancement update 2015-11-23 21:13:16 UTC

Description Marek Stana 2015-03-20 16:50:14 UTC
Description of problem:
When you are using libreoffice base component  and try to edit some already created table you open edit window and its not in the same group as libre office base. Its happening in many other cases as:
 - create form in design view
 - create report in design view
 - etc.

Version-Release number of selected component (if applicable):
libreoffice-base-4.2.6.3-5.el7.x86_64


How reproducible:
Use libreoffice base and try to edit some table in this program. When you hit <alt>+<tab> you see that libreoffice edit window is in group libreoffice not libreoffice base.

Steps to Reproduce:
1. Open libreoffice base
2. Create random table
3. Save table
4. double click on label with name of table in Tables
5. new window pop up
6. press <alt> + <tab> and release <tab>
7. you can see that edit windows have different label and also is not in group with libreoffice base

Actual results:
edit window have label LibreOffice and is in different group than other libreoffice base windows 

Expected results:
edit window should be in group libreoffice base as other libreoffice base windows


Additional info:

Comment 2 Caolan McNamara 2015-03-23 10:51:18 UTC
http://cgit.freedesktop.org/libreoffice/core/commit/?id=9450d7e7089aab4b14a669bf947cc34ae0f6b892

group all the "sdb", staroffice database I guess, together as "Base" rather than try and list every individual case

Comment 5 Bill Sanford 2015-09-11 13:49:07 UTC
Verified with RHEL-7.2-20150904.0 & libreoffice-4.3.7.2-5.el7.x86_64

Comment 7 errata-xmlrpc 2015-11-23 16:14:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2197.html


Note You need to log in before you can comment on or make changes to this bug.