Bug 120425 - Installer crashed (mkfs.ext3 formatting crashed as well)
Installer crashed (mkfs.ext3 formatting crashed as well)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 13:33 EDT by Mark
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-11 14:24:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2004-04-08 13:33:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) Opera 
7.23  [en]

Description of problem:
I've tried to install Fedora Core 1 several times but installer 
crashed each and every single time.
First couple of times it crashed during partitioning process.
I tried both graphical and text installation
Selected Personal Desktop , and everything default.
Hard drive is Maxtor 6E040L0, motherboard is Asus P4SDX with 512 MB 
of Azen DDR Ram (PC2700) and processor is Intel P4 1.8 GHZ.
On first IDE controller I have old Quantum Fireball 20 GB with 
Windows 2000 installation.
Windows 2000 works fine with all hardware.
I accepted default partitioning on slave /dev/hdb drive and didn't 
wan't to install bootloader (didn't want to mess partition table on 
first drive /dev/hda Quantum Fireball -> 20 GB drive with Windows 
2000 on it).
I've also attempted to try and fake , go through rescue mode and do 
partitioning from command line with fdisk.
Was able to create good partition table with 4 partitions.
Firsta partition was primary of type 83 with 100 MB (/dev/hdb1).I 
wanted to use it as /boot.Second partition was primary as well type 
83 with 5 GB (/dev/hdb2).It was supposed to be used as / partition.
Third partition was primary with 512 MB of type 82 (linux swap 
/dev/hdb3).
Fourth partition was logical in extended partition (/dev/hdb4) and 
was supposed to be used as /home. (/dev/hdb5 filled the rest of the 
disk space 30 and something GB).
Partiton table was successfuly verified (there was 64 unallocated 
sectors), and written but formatting failed on partition /dev/hdb2 ( 
I tried mkfs.ext3 -j /dev/hdb2 , it started well and it just crashed, 
 giving some core dump.
I tried again and mkfs hang forever.
Partitioning worked well on /dev/hdb1 before this crash(small 100MB 
/boot partition) but also failed on big /home partition after reboot.
After this I've partitioned and formatted this drive with Partition 
Magic in Windows 2000.
Installation started well this time, image was copied to HD and than  
crashed midway through while it was installing some package (X server 
stopped and I got rebooting message - don't know what was reason for 
collapse)
Video card is Nvidia GeForce 4 , and monitor was some old 15 inch 
monitor (LKM or something like that, was detected fine with Knoppix).
Then I've put this drive in my other PC (Athlon 1GHZ and was able to 
detect it as slave on first IDE controller).
I have Fedora Core 1 installed on this PC.I was able to create one 
large ext3 partition on this Maxtor drive and format it with mkfs.
ext3 -j /dev/hdb1 
Was able to mount it and read and write data (copied several large 
files - Divx movies , both from other drive and CD-RW drive)




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Insert CD1,CD2, CD3 test them and continue with installation
2.Select graphical or text installation 
3.Select Personal Desktop and autoformating
    

Actual Results:  installation crashed

Expected Results:  good installation

Additional info:

I've tried formatting this drive in windows 2000 and it worked fine, 
so really don't have idea what's going on.
Comment 1 Mark 2004-04-08 13:40:09 EDT
I have LG 8x / 12x / 24x CD-RW drive connected as master on second 
IDE controller (used autodetect in BIOS)
Comment 2 Mark 2004-04-10 23:51:09 EDT
I've replaced 512 MB of Azen DDR RAM memory with 512 MB of Kingston
DDR RAM and everything started clicking.I've installed Fedora without
any further problem.
I am not sure if this should be considered a bug, because this looks
like a hardware problem, but I didn't have problems running Windows
2000 with this Azen RAM.
Comment 3 Jeremy Katz 2004-04-11 14:24:07 EDT
Sounds like a hardware bug to me

Note You need to log in before you can comment on or make changes to this bug.