Bug 120428 - [PATCH] dhclient -s IP fails(hangs) if no default route
[PATCH] dhclient -s IP fails(hangs) if no default route
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcpcd (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 14:26 EDT by Dmitry Sazonov
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 11:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Sazonov 2004-04-08 14:26:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
added in /etc/sysconfig/network
DHCLIENTARGS="-s 143.220.3.171"

so ifup eth0 would trigger dhclient -s IP ... 
that hangs because /sbin/dhclient-script  in PREINIT section
doesn't setup default route (like it does for v2 of the pkg - see if case)
if added route back and if works. Apparently dhclinet cannot ACK
DHCPOFFER if no default route.


# diff -c /sbin/dhclient-script.old /sbin/dhclient-script
*** /sbin/dhclient-script.old   2004-04-08 14:22:50.000000000 -0400
--- /sbin/dhclient-script       2004-04-08 14:05:08.000000000 -0400
***************
*** 122,127 ****
--- 122,128 ----
      route add default dev $interface netmask 0.0.0.0
    else
      ifconfig $interface 0 up
+     route add default dev $interface netmask 0.0.0.0
    fi

    # We need to give the kernel some time to get the interface up.


Version-Release number of selected component (if applicable):
dhclient-3.0pl2-6.14

How reproducible:
Always

Steps to Reproduce:
1. update network file with -s dhcp-IP (see description)
2. ifdown eth0; ufup eth0 (hangs)
3.
    

Actual Results:  ifup eth0 hangs

Expected Results:  ifup eth0 succeeds

Additional info:
Comment 1 Daniel Walsh 2004-06-10 13:44:02 EDT
Added patch in dhcp-3.0.1rc12-9
Comment 2 John Flanagan 2004-12-21 14:42:00 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html

Note You need to log in before you can comment on or make changes to this bug.