Bug 120432 - FTP install using DNS lookup crashes with SIG-11
FTP install using DNS lookup crashes with SIG-11
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 15:25 EDT by Ron Flory
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:16:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Flory 2004-04-08 15:25:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
When attempting a FTP install of FC2 Test2 with anonymous
FTP login using a symbolic name (DNS), the process crashes
after several minutes with a SIG-11.

 As a test I performed the same operations using
same machine and RedHat 9.0, and RedHat 8.0 .  Both
worked with no problems at all.

- Using EPIC100 eth driver.
- Looking at the debug screens, we were able to obtain
  a DHCP lease OK.


Version-Release number of selected component (if applicable):
installer

How reproducible:
Always

Steps to Reproduce:
1. boot CD
2. specify FTP install
3. supply symbolic name instead of raw IP address
    

Actual Results:  after several minute delay, screen was filled with
unreadable Cyrillic
chars, but the last line said "Signal 11"

 My FTP server was never accessed.

Expected Results:  actually access FTP server.

Additional info:
Comment 1 Jeremy Katz 2004-04-11 14:27:51 EDT
What language are you using for the install?  What ftp server are you
using?
Comment 2 Ron Flory 2004-04-12 08:08:44 EDT
Language:   English
FTP server: RH7.2 (x86)
Real Name:  Ron Flory [USA] (ron.flory@adtran.com)

 In truth, I suspect the issue is really a DNS lookup
problem.  If I supply a dotted-quad IP instead of a
machine name, the install continues without any 
problems.

 If I use a DNS name for ther FTP server the FTP server
is not even contacted (yes, I monitor the logs).

ron
Comment 3 Jeremy Katz 2004-04-12 23:59:29 EDT
This is done all the time by me when testing -- are you getting a DNS
server to use when getting your dhcp lease (if you hit back, you
should see the values filled in on the newt form :)

Note You need to log in before you can comment on or make changes to this bug.