Bug 1204320 - IOError: [Errno 9] Bad file descriptor
Summary: IOError: [Errno 9] Bad file descriptor
Keywords:
Status: CLOSED DUPLICATE of bug 1103450
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a123d290463e809be075ab1d204...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-21 00:43 UTC by Wendell Baker
Modified: 2015-03-23 13:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-23 13:20:17 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (223.56 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: anaconda.log (9.42 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: environ (405 bytes, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: lsblk_output (988 bytes, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: nmcli_dev_list (8.81 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: os_info (375 bytes, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: program.log (26.80 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: storage.log (28.17 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: syslog (114.17 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: ifcfg.log (1.36 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details
File: packaging.log (1.39 KB, text/plain)
2015-03-21 00:43 UTC, Wendell Baker
no flags Details

Description Wendell Baker 2015-03-21 00:43:15 UTC
Description of problem:
Installing Fedora 20 on a Stylistic ST-6012 x86_64
This configuration has installed flawlessly on several other units.
Anaconda doesn't seem to check error conditions or recover well from any unexpected exception.

Version-Release number of selected component:
anaconda-20.25.15-1

The following was filed automatically by anaconda:
anaconda 20.25.15-1 exception report
Traceback (most recent call first):
  File "<string>", line 100, in next
  File "/usr/lib/yum-plugins/blacklist.py", line 47, in exclude_hook
    for event, elem in iterparse(infile):
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 188, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 784, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1050, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 904, in _getGroups
    self.pkgSack
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1073, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3760, in selectGroup
    if not self.comps.has_group(grpid):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1091, in _selectYumGroup
    self._yum.selectGroup(groupid, group_package_types=pkg_types)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1199, in _applyYumSelections
    self._selectYumGroup("core")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1273, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 124, in checkSoftwareSelection
    self.payload.checkSoftwareSelection()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 192, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 9] Bad file descriptor

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=F20/x86_64/isolinux/initrd.img vnc headless shell sshd ksdevice=link lang=en_US keymap=us repo=nfs:vers=3:pickerel:/lake/fedora/20/trees/Fedora-20-x86_64-DVD BOOT_IMAGE=F20/x86_64/isolinux/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20

Comment 1 Wendell Baker 2015-03-21 00:43:24 UTC
Created attachment 1004703 [details]
File: anaconda-tb

Comment 2 Wendell Baker 2015-03-21 00:43:27 UTC
Created attachment 1004704 [details]
File: anaconda.log

Comment 3 Wendell Baker 2015-03-21 00:43:28 UTC
Created attachment 1004705 [details]
File: environ

Comment 4 Wendell Baker 2015-03-21 00:43:29 UTC
Created attachment 1004706 [details]
File: lsblk_output

Comment 5 Wendell Baker 2015-03-21 00:43:30 UTC
Created attachment 1004707 [details]
File: nmcli_dev_list

Comment 6 Wendell Baker 2015-03-21 00:43:32 UTC
Created attachment 1004708 [details]
File: os_info

Comment 7 Wendell Baker 2015-03-21 00:43:33 UTC
Created attachment 1004709 [details]
File: program.log

Comment 8 Wendell Baker 2015-03-21 00:43:35 UTC
Created attachment 1004710 [details]
File: storage.log

Comment 9 Wendell Baker 2015-03-21 00:43:38 UTC
Created attachment 1004711 [details]
File: syslog

Comment 10 Wendell Baker 2015-03-21 00:43:39 UTC
Created attachment 1004712 [details]
File: ifcfg.log

Comment 11 Wendell Baker 2015-03-21 00:43:39 UTC
Created attachment 1004713 [details]
File: packaging.log

Comment 12 David Shea 2015-03-23 13:20:17 UTC

*** This bug has been marked as a duplicate of bug 1103450 ***


Note You need to log in before you can comment on or make changes to this bug.