Bug 1204341 - cannot record hydrogen output with audacity, using jack or not, 2 notebooks, 1 PC
Summary: cannot record hydrogen output with audacity, using jack or not, 2 notebooks, ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 22
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-21 06:22 UTC by Kevin Tough
Modified: 2015-08-01 02:29 UTC (History)
4 users (show)

Fixed In Version: audacity-2.1.1-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-30 01:16:04 UTC
Type: Bug


Attachments (Terms of Use)
Console Error Messages Jack Running (80.44 KB, text/plain)
2015-07-16 11:58 UTC, Kevin Tough
no flags Details
Screenshot Jack running, input dropdown with Jack (576.61 KB, image/png)
2015-07-16 12:01 UTC, Kevin Tough
no flags Details
Console Text Messages Audacity start without Jack running (88.30 KB, text/plain)
2015-07-16 12:03 UTC, Kevin Tough
no flags Details

Description Kevin Tough 2015-03-21 06:22:20 UTC
Description of problem:In f21 or f22. I cannot record hydrogen's output with audacity without in best case audacity's output being 90% of the time garbeled (Asus F55a). With PC audacity freezes when it attempts to hook up to jack. With a Fujitsu Simens amilio xi 2550 audacity freezes as well. Without jack none of my systems are able to record and playback without error. If recording works I have to shut down hydrogen, save the audacity file. restart audacity and I can playback the file then. 


Version-Release number of selected component (if applicable):


How reproducible:Always, I think Jam gives me the same trouble if I remember correctly.


Steps to Reproduce:
1.Start jack
2.Start hydrogen
3.Start hydrogen playback
4.Start Audacity
5.Select jack as input and output if not already and not frozen
6.Try to record
7.Try to playback

Actual results:Varied as mentioned above


Expected results:Audacity should playback on top of hydrogen if it is still providing output. Audacity should playback if hydrogen's output is stopped without closing hydrogen.


Additional info: I don't know if it helps but my hardware works in ubuntu or kxstudio but I'd rather stay with fedora.

Comment 1 Kevin Tough 2015-03-21 06:26:39 UTC
Would changing the desktop to Xfce make any difference?

Comment 2 David Timms 2015-03-22 12:42:02 UTC
It isn't something I have tried as I use Audacity with pulseaudio sound system, but it sounds like you know how to set up jack properly. Do the audio paths look correct in qjackctl ?

How about sample rates; do these match your hardware, or is there a lot of resampling going on.

What is the latest software versions that worked under Fedora (ie has this recently begun occurring, or has it never worked properly) ?

Comment 3 Kevin Tough 2015-03-22 21:25:07 UTC
(In reply to David Timms from comment #2)
> It isn't something I have tried as I use Audacity with pulseaudio sound
> system, but it sounds like you know how to set up jack properly. Do the
> audio paths look correct in qjackctl ?
> 
> How about sample rates; do these match your hardware, or is there a lot of
> resampling going on.
> 
> What is the latest software versions that worked under Fedora (ie has this
> recently begun occurring, or has it never worked properly) ?

In the connections GUI something interesting happens, at least on the Fujitsu Siemens notebook. If I pay close attention sometimes I will see an entry in readable clients blink for Audacity and immediately disappear. Also in the writable clients I think I may have once seen a fleeting Pulse Audio client blink. The PC also has no readable client for Audacity.
Your question about resampling is something I am not aware of or know what to check for. I know Xruns are bad and I have the settings such that I do not have many of them.
This issue is new for myself as I am just starting to look at my options for low latency recording in my hobby home studio. I tried F22 on my notebook ASUS F55a hoping for a fix but it had the same problems as F21. Older versions I did not try this with.

Comment 4 Kevin Tough 2015-04-09 20:11:14 UTC
Will this bug be worked on? If I am not mistaken Fedora Jam has the same problem.

Namaste,
Kevin Tough

Comment 5 Darryl L. Pierce 2015-04-09 20:15:19 UTC
(In reply to Kevin Tough from comment #4)
> Will this bug be worked on? If I am not mistaken Fedora Jam has the same
> problem.
> 
> Namaste,
> Kevin Tough

This is likely something you should bring upstream to the Audacity development team. At the Fedora level I only package the code and don't actively develop it.

Comment 6 Fedora Admin XMLRPC Client 2015-06-12 13:11:12 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Fedora Update System 2015-06-29 13:27:30 UTC
audacity-2.1.1-0.1.dea351a.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.1.dea351a.fc22

Comment 8 David Timms 2015-07-03 12:16:52 UTC
Hi Kevin, I was going to try your reproducer, but "jack" isn't found. Would you be able to clarify your actions, performing them from eg gnome-terminal prompt, so that I may follow your steps to the letter ?

Also, I've packaged Audacity 2.1.1 pre-alpha, which may change or stop this issue occurring, are you able to re-test with this, please ?

Comment 9 Kevin Tough 2015-07-03 13:02:37 UTC
(In reply to David Timms from comment #8)
> Hi Kevin, I was going to try your reproducer, but "jack" isn't found. Would
> you be able to clarify your actions, performing them from eg gnome-terminal
> prompt, so that I may follow your steps to the letter ?
> 
> Also, I've packaged Audacity 2.1.1 pre-alpha, which may change or stop this
> issue occurring, are you able to re-test with this, please ?

Hi David,
this weekend is very full but I will attempt to try and test. I noticed the update mentioned in comment 7 was installed to my machine yesterday. Last night just before bed I was able to see that Audacity will now record from Hydrogen without crashing. now if I can just get the output of Jack routed to the proper output things should be looking much better.
How do I check for Audacity 2.1.1 pre-alpha or know that it has been updated to my machines?

Above in the first section about how to reproduce I had used the Gnome desktop and not the command line. If I am able to figure out how to do this from the command line will there be a dmesg file written that could be helpful for you or does that happen also when using the GUI?

Time allowing I will try this on my 32 bit notebook and my 64 bit buro machine. Will these updates be updated in Fedora Jam imediately as well? I had to switch OS on my music studio notebook to KXStudio because at the bare minimum I needed this recording functionality.

I'll try to get to testing, many thanks, Kevin

Comment 10 Fedora Update System 2015-07-05 04:23:26 UTC
audacity-2.1.1-0.2.rc1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.2.rc1.fc22

Comment 11 Fedora Update System 2015-07-05 04:23:42 UTC
audacity-2.1.1-0.2.rc1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.2.rc1.fc21

Comment 12 Kevin Tough 2015-07-06 05:13:44 UTC
Currently on my Fedora 22 Notebook Audacity will not even start. At first came a window suggesting to register effects, which I have previously never seen. The list of plugins had entries like  adsr_1653, alias_1407 and  am_pitchshift_1453.

After pressing enter and a short wait comes the Oops, we're sorry, it looks like Audacity has crashed. This has been automatically reported.

Comment 13 Fedora Update System 2015-07-12 22:44:14 UTC
audacity-2.1.1-0.4.rc3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.4.rc3.fc22

Comment 14 Fedora Update System 2015-07-12 22:44:30 UTC
audacity-2.1.1-0.4.rc3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.4.rc3.fc21

Comment 15 Fedora Update System 2015-07-14 15:28:34 UTC
Package audacity-2.1.1-0.4.rc3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audacity-2.1.1-0.4.rc3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11488/audacity-2.1.1-0.4.rc3.fc22
then log in and leave karma (feedback).

Comment 16 Kevin Tough 2015-07-16 11:58:39 UTC
Created attachment 1052661 [details]
Console Error Messages Jack Running

Comment 17 Kevin Tough 2015-07-16 12:01:42 UTC
Created attachment 1052663 [details]
Screenshot Jack running, input dropdown with Jack

Comment 18 Kevin Tough 2015-07-16 12:03:05 UTC
Created attachment 1052665 [details]
Console Text Messages Audacity start without Jack running

Comment 19 Kevin Tough 2015-07-16 12:05:14 UTC
With Jack not running I can now record the default system (mic) input.

With Jack running I cannot record. I am including the console text messages and a couple of screenshots. Two things of interest from my point of view.
1. Hydrogen output causes the timer display in the Jack Audio Connection Kit to run, otherwise it remains at 00.00.00.
2. Audacity, when started while Hydrogen is outputting behaves differently when started from the Gnome 3 icon or the command line. From the command line Audacity starts with the entry "default" in both input and output dropdown boxes. Started from the Gnome icon Audacity automatically enters Jack in the input dropdown box.
Now that Audacity starts with Jack entered as the input source it is active, the menus work. When I try to record Audacity freezes and must be forced to quit. It causes an entry in Jack Connections called "alsa-jack.jackC.3591.39" to appear. This remains until Audacity is killed.
If started from the console I do not have an input choice for Jack. Audacity when recording just blinks a cursor at 0.0 on and off and does not record anything.
I hope the included files are helpful.

Comment 20 Fedora Update System 2015-07-19 09:04:35 UTC
audacity-2.1.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-1.fc22

Comment 21 Fedora Update System 2015-07-19 09:06:26 UTC
audacity-2.1.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/audacity-2.1.1-1.fc21

Comment 22 Fedora Update System 2015-07-30 01:16:04 UTC
audacity-2.1.1-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2015-08-01 02:29:16 UTC
audacity-2.1.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.