Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1204393 - Mouse pointer is erratic in GNOME on Wayland and VMware Fusion
Summary: Mouse pointer is erratic in GNOME on Wayland and VMware Fusion
Keywords:
Status: CLOSED DUPLICATE of bug 1214474
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-21 15:34 UTC by Torsten Scholak
Modified: 2015-05-15 13:57 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-15 13:57:46 UTC
Type: Bug


Attachments (Terms of Use)
journalctl -b output using wayland session (339.43 KB, text/plain)
2015-05-13 21:23 UTC, Everaldo Canuto
no flags Details

Description Torsten Scholak 2015-03-21 15:34:54 UTC
Description of problem:
The GUI is difficult to navigate, because upon capturing the mouse from outside VMware and moving the mouse pointer for the first time, the pointer jumps to an edge of the screen in a seemingly unpredictable pattern. This typically results in the mouse being un-captured, making it necessary to repeat the process.

I realize that it is very possible that VMware's automatic mouse capturing feature is to blame here. Maybe it is not yet optimized for Wayland. However, I recommend looking into this, because many people will want to check out GNOME on Wayland in a VM and not on bare metal. The problem described here makes this endeavour a rather annoying experience.

Version-Release number of selected component (if applicable):
Fedora 22
GNOME 3.15.92
VMware Fusion 7.1.1 (2498930)

How reproducible:
Always.

Steps to Reproduce:
1. From within the host os (in my case, Mac OS Yosemite 10.10.3 public beta), click into the VMware window.
2. Move the mouse.

Actual results:
See above.

Expected results:
The mouse pointer should move according to the actual movement of the mouse.

Additional info:
None so far.

Comment 1 Torsten Scholak 2015-03-21 15:50:44 UTC
One more thing:
It's semantics, but the term "automatic mouse capturing" is not used by VMware. They call it "seamless mouse integration", "mouse grabbing" or similar. In VMware Fusion (i.e. on Macs), it can be deactivated by selecting "Always optimize mouse for games" in the General preferences pane. Switching to this setting doesn't solve the jumping pointer issue, but at least the mouse remains trapped inside the VM.

Comment 2 Everaldo Canuto 2015-04-22 15:41:15 UTC
I also have this problem when use normal GNOME session (I supposed it uses X instead of Wayland). Could it be a problem on open-vm-tools?

Anyway, I think that it is very important to fix this problem since it works nice on Fedora 21.

Comment 3 Everaldo Canuto 2015-04-22 15:41:57 UTC
One more question. Should a fill a new bug report for X11 ?

Comment 4 Sterling Windmill 2015-05-01 01:01:15 UTC
I am also affected by this when running Fedora 22 inside of VMware Workstation 11 running on a Windows 8.1 host. The problem appears to be worse when I am running the VM spanned across multiple monitors (the host machine has three monitors).

Comment 5 Jim Adkins 2015-05-05 18:06:53 UTC
Ditto for me, running Fedora 22 in VMWare Player 6.0.5 build-2443746 on Windows 7 (64 bit).

The pointer appears to be in the correct position, but when I click the mouse button (any of them), the pointer jumps to the top of the screen (usually to the same location; just left of center).

This was occurring in the Alpha version as well as recent Beta. 

Fedora 21 and previous versions all work flawlessly with this setup.

Comment 6 Jim Adkins 2015-05-07 13:19:35 UTC
Problem still occurs using latest VMWare player update (6.0.6 build-2700073) released on 2015-05-06.

You get occasional click-glitches after initial VM launch, but the issue really worsens to the point where Fedora 22 is unusable, once you click outside of the VM instance, then return focus to the VM.

Comment 7 Everaldo Canuto 2015-05-07 13:35:49 UTC
I think that nobody is looking at the problem. Anyone know how we can help get it fixed before Fedora 22 final?

Comment 8 Torsten Scholak 2015-05-07 13:39:35 UTC
IRC?

Comment 9 Everaldo Canuto 2015-05-07 13:41:34 UTC
Maybe. Any ideal about IRC channel used for bugs?

Comment 10 Torsten Scholak 2015-05-07 13:51:36 UTC
I went to fedora-devel. People suggested to change the component to gnome-shell and to inform also vmware about it. Have only done the former so far.

Comment 11 Everaldo Canuto 2015-05-13 21:23:29 UTC
Created attachment 1025198 [details]
journalctl -b output using wayland session

Maybe journalctl -b output could be useful.

Comment 12 Rui Matos 2015-05-14 09:49:32 UTC
I'm afraid that vmware relies on the X vmmouse to work reliably. Since that's an X lever driver it obviously doesn't work in a native wayland session so I don't think there's any easy fix for this short of vmware changing their driver to work at the kernel level so that native wayland compositors can use it too.

Comment 13 Sterling Windmill 2015-05-15 05:25:49 UTC
I'll note that this is actually not specific to Wayland. I see the same issue when logging into a standard (non Wayland) GNOME session on Fedora 22 inside of VMware Workstation 11 running on Windows 8.1

Comment 14 Everaldo Canuto 2015-05-15 09:26:53 UTC
(In reply to Sterling Windmill from comment #13)
> I'll note that this is actually not specific to Wayland. I see the same
> issue when logging into a standard (non Wayland) GNOME session on Fedora 22
> inside of VMware Workstation 11 running on Windows 8.1

Yes, we already have #1214474 for standard GNOME session. We just need to check if solution applied for 1214474 works also for Wayland.

Comment 15 Everaldo Canuto 2015-05-15 09:47:20 UTC
Can someone mark this as duplicate of #1214474 ? I have just checked and is the same issue.

Comment 16 Rui Matos 2015-05-15 13:57:46 UTC
It's not strictly a duplicate but the fix Hans proposes, including the kernel vmmouse driver in fedora's kernel, means this would be fixed too so yeah, let's dupe it.

*** This bug has been marked as a duplicate of bug 1214474 ***


Note You need to log in before you can comment on or make changes to this bug.