Bug 1204521 - fr_CH LC_TIME has wrong first day of week
Summary: fr_CH LC_TIME has wrong first day of week
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Weimer
QA Contact: Fedora Extras Quality Assurance
Florian Weimer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-22 21:32 UTC by Heldwin
Modified: 2016-05-15 04:51 UTC (History)
7 users (show)

Fixed In Version: glibc-2.22-16.fc23, glibc-2.23.1-7.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-15 04:51:19 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Sourceware 19568 0 None None None 2019-06-01 15:49:31 UTC

Description Heldwin 2015-03-22 21:32:58 UTC
Description of problem:
In Switzerland, the first day of the week is monday, not sunday.

In /usr/share/i18n/locales/fr_CH, there are missing parameters in LC_TIME:
first_weekday 2
first_workday 2


Version-Release number of selected component (if applicable):
glibc-common-2.20-8.fc21.x86_64
(also present in f20 and f22)


How reproducible:
Always


Steps to Reproduce:
1. install fedora with fr_CH
2. open clock-applet in mate (by example)


Actual results:
First day is Sunday, not Monday


Expected results:
First day is Monday


Additional info:

After you add the three lines at the end of LC_TIME, to be effective, I had to use:

localedef -v -c -i fr_CH -f UTF-8 fr_CH.UTF-8

then, the file: /usr/lib/locale/locale-archive is modified with the new info.

If I look bug #624296, I cannot find an official info telling explicitly that monday is the first day of the week.

Comment 1 Heldwin 2015-05-27 20:58:11 UTC
de_CH, that is in the same country than for fr_CH (Switzerland) has it already
(fr_FR, de_DE, etc. have it too)

Would it be possible to do it too for fr_CH ?

Comment 2 Heldwin 2015-05-27 21:29:56 UTC
it_CH doesn't get this change too though.

So if it is possible for fr_CH, probably would help to change it for it_CH too :)

Comment 3 Heldwin 2016-05-09 22:40:18 UTC
Hello,

Will the CLDR import that is in glibc master be backported to f23 too ?

Comment 4 Florian Weimer 2016-05-10 06:54:18 UTC
(In reply to Heldwin from comment #3)
> Hello,
> 
> Will the CLDR import that is in glibc master be backported to f23 too ?

No, but we can (and eventually will) fix individual locale issues users report.

I want bugs for any such change so that users have a way of finding out what changed and why (“CLDR import” is not very illuminating).

Comment 5 Heldwin 2016-05-10 18:06:10 UTC
ok, but may I hope this report about fr_CH will be fixed too ?

I also don't understand why it was fixed for es_CL (#1321372), and not fr_CH.

For reference, 
for es_CL, it was Reported in 2016-03-25 16:34 EDT
for fr_CH, it was reported in 2015-03-22 17:32 EDT 

so this one was reported about 1 year before.

Can you please explain it to me (because the reason is not very illuminating too).
Thanks

Comment 6 Florian Weimer 2016-05-10 18:55:16 UTC
(In reply to Heldwin from comment #5)
> ok, but may I hope this report about fr_CH will be fixed too ?

Yes, eventually, probably as part of the next update.

> I also don't understand why it was fixed for es_CL (#1321372), and not fr_CH.

I picked up bugs in reverse chronological filing order, and had to stop at some point to actually get *some* bug fixes out.

Comment 7 Fedora Update System 2016-05-11 11:19:58 UTC
glibc-2.22-16.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b0e67c88b5

Comment 8 Fedora Update System 2016-05-11 13:56:21 UTC
glibc-2.23.1-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b321728d74

Comment 9 Fedora Update System 2016-05-11 13:56:44 UTC
glibc-2.23.1-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b321728d74

Comment 10 Fedora Update System 2016-05-12 09:34:19 UTC
glibc-2.22-16.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b0e67c88b5

Comment 11 Fedora Update System 2016-05-12 09:44:41 UTC
glibc-2.23.1-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b321728d74

Comment 12 Heldwin 2016-05-12 17:32:27 UTC
Thanks a lot, the update glibc-2.22-16.fc23 fixes it.

Comment 13 Fedora Update System 2016-05-12 20:53:42 UTC
glibc-2.22-16.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-05-14 23:30:38 UTC
glibc-2.23.1-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.