Bug 1204614 - Review Request: gofed - Tool for development of golang devel packages
Summary: Review Request: gofed - Tool for development of golang devel packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ondrej Oprala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 07:32 UTC by Jan Chaloupka
Modified: 2016-02-01 02:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-26 03:21:13 UTC
Type: ---
Embargoed:
ooprala: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Jan Chaloupka 2015-03-23 07:32:41 UTC
Spec URL: https://jchaloup.fedorapeople.org/reviews/gofed/gofed.spec

SRPM URL: https://jchaloup.fedorapeople.org/reviews/gofed/gofed-0-0.1.git837cc97.fc20.src.rpm

Description: Tool to automize packaging of golang devel source codes.
The main goal is to automatize packaging (spec file generator),
dependency discovering, testing (scratch builds), to prepare package review.
If possible, all in one command.

Fedora Account System Username: jchaloup

Koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=9300319

$ rpmlint gofed-0-0.1.git837cc97.fc20.src.rpm gofed-0-0.1.git837cc97.fc20.x86_64.rpm gofed.spec
gofed.src: W: spelling-error Summary(en_US) devel -> delve, devil, revel
gofed.src: W: spelling-error %description -l en_US automize -> atomize, automatize
gofed.src: W: spelling-error %description -l en_US devel -> delve, devil, revel
gofed.src:4: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 4)
gofed.x86_64: W: spelling-error Summary(en_US) golang -> Angolan, Golan, Angola
gofed.x86_64: W: spelling-error Summary(en_US) devel -> delve, devil, revel
gofed.x86_64: W: spelling-error %description -l en_US automize -> atomize, automatize
gofed.x86_64: W: spelling-error %description -l en_US golang -> Angolan, Golan, Angola
gofed.x86_64: W: spelling-error %description -l en_US devel -> delve, devil, revel
gofed.x86_64: W: incoherent-version-in-changelog 0-0.1.git3b5f081 ['0-0.1.git837cc97.fc20', '0-0.1.git837cc97']
gofed.x86_64: E: arch-dependent-file-in-usr-share /usr/share/gofed/parseGo
gofed.x86_64: W: unstripped-binary-or-object /usr/share/gofed/parseGo
gofed.x86_64: E: statically-linked-binary /usr/share/gofed/parseGo
gofed.x86_64: W: non-etc-or-var-file-marked-as-conffile /usr/share/gofed/config/gofed.conf
gofed.x86_64: W: conffile-without-noreplace-flag /usr/share/gofed/config/gofed.conf
gofed.x86_64: W: non-conffile-in-etc /etc/bash_completion.d/gofed
gofed.x86_64: W: dangerous-command-in-%post ln
gofed.x86_64: W: dangerous-command-in-%preun rm
gofed.spec:4: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 4)
2 packages and 1 specfiles checked; 2 errors, 17 warnings.

Comment 1 Jan Chaloupka 2015-03-23 09:21:17 UTC
Upstream: https://github.com/fedora-cloud/gofed

Notes: ignore "gofed.x86_64: E: arch-dependent-file-in-usr-share /usr/share/gofed/parseGo" as this package is still in an experimental state.

Comment 2 Ondrej Oprala 2015-03-26 17:51:09 UTC
=====
fedora-review output with my comments, denoted by '>>>'
=====




This is a review *template*. Besides handling the [ ]-marked tests you are
also supposed to fix the template before pasting into bugzilla:
- Add issues you find to the list of issues on top. If there isn't such
  a list, create one.
- Add your own remarks to the template checks.
- Add new lines marked [!] or [?] when you discover new things not
  listed by fedora-review.
- Change or remove any text in the template which is plain wrong. In this
  case you could also file a bug against fedora-review
- Remove the "[ ] Manual check required", you will not have any such lines
  in what you paste.
- Remove attachments which you deem not really useful (the rpmlint
  ones are mandatory, though)
- Remove this text



Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- No %config files under /usr.
  Note: %config /usr/share/gofed/config/gofed.conf
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#Configuration_files
- Package does not contain duplicates in %files.
  Note: warning: File listed twice: /usr/share/gofed/config/gofed.conf
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#DuplicateFiles


===== MUST items =====

Generic:
[ ]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
>>> OK - LICENSE file present in the project with a GPL License description
[ ]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "GPL (v2 or later)", "Unknown or generated". 25 files have unknown
     license. Detailed output of licensecheck in
     /home/ooprala/.vim/gofed/licensecheck.txt
>>> OK - Checks out
[ ]: %build honors applicable compiler flags or justifies otherwise.
>>> OK - go compiler
[ ]: Package contains no bundled libraries without FPC exception.
>>> OK
[ ]: Changelog in prescribed format.
>>> FAILED - version doesn't match %global commit
[ ]: Sources contain only permissible code or content.
>>> OK
[ ]: %config files are marked noreplace or the reason is justified.
     Note: No (noreplace) in %config /usr/share/gofed/config/gofed.conf
>>> FAILED
[ ]: Package contains desktop file if it is a GUI application.
>>> OK
[ ]: Development files must be in a -devel package
>>> OK
[ ]: Package uses nothing in %doc for runtime.
>>> OK
[ ]: Package consistently uses macros (instead of hard-coded directory names)
>>> OK
[ ]: Package is named according to the Package Naming Guidelines.
>>> OK
[ ]: Package does not generate any conflict.
>>> FAILED - %postun and %preun
[ ]: Package obeys FHS, except libexecdir and /usr/target.
>>> OK
[ ]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
>>> OK
[ ]: Requires correct, justified where necessary.
>>> OK
[ ]: Spec file is legible and written in American English.
>>> OK
[ ]: Package contains systemd file(s) if in need.
>>> OK - none needed
[ ]: Useful -debuginfo package or justification otherwise.
>>> OK - No debuginfo for golang stuff
[ ]: Package is not known to require an ExcludeArch tag.
>>> OK - ExclusiveArch
[ ]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 30720 bytes in 2 files.
>>> OK - not applicable
[ ]: Package complies to the Packaging Guidelines
>>> OK
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
>>> OK - packager == upstream
[ ]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[ ]: Final provides and requires are sane (see attachments).
[ ]: Package functions as described.
[ ]: Latest version is packaged.
[ ]: Package does not include license text files separate from upstream.
[ ]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[!]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
     Note: Arch-ed rpms have a total of 21872640 bytes in /usr/share
     gofed-0-0.1.gitcab0f0b.fc21.x86_64.rpm:21872640
     See:
     http://fedoraproject.org/wiki/Packaging:ReviewGuidelines#Package_Review_Guidelines
>>> OK - This should be ok
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).


Rpmlint
-------
Checking: gofed-0-0.1.gitcab0f0b.fc21.x86_64.rpm
          gofed-0-0.1.gitcab0f0b.fc21.src.rpm
gofed.x86_64: W: spelling-error Summary(en_US) golang -> Angolan, Golan, Angola
gofed.x86_64: W: spelling-error Summary(en_US) devel -> delve, devil, revel
gofed.x86_64: W: spelling-error %description -l en_US automize -> atomize, automatize
gofed.x86_64: W: spelling-error %description -l en_US golang -> Angolan, Golan, Angola
gofed.x86_64: W: spelling-error %description -l en_US devel -> delve, devil, revel
gofed.x86_64: W: incoherent-version-in-changelog 0-0.1.git3b5f081 ['0-0.1.gitcab0f0b.fc21', '0-0.1.gitcab0f0b']
gofed.x86_64: E: arch-dependent-file-in-usr-share /usr/share/gofed/parseGo
gofed.x86_64: W: unstripped-binary-or-object /usr/share/gofed/parseGo
gofed.x86_64: E: statically-linked-binary /usr/share/gofed/parseGo
gofed.x86_64: W: non-etc-or-var-file-marked-as-conffile /usr/share/gofed/config/gofed.conf
gofed.x86_64: W: conffile-without-noreplace-flag /usr/share/gofed/config/gofed.conf
gofed.x86_64: W: non-conffile-in-etc /etc/bash_completion.d/gofed
gofed.x86_64: W: dangerous-command-in-%post ln
gofed.x86_64: W: dangerous-command-in-%preun rm
gofed.src: W: spelling-error Summary(en_US) devel -> delve, devil, revel
gofed.src: W: spelling-error %description -l en_US automize -> atomize, automatize
gofed.src: W: spelling-error %description -l en_US devel -> delve, devil, revel
gofed.src:4: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 4)
2 packages and 0 specfiles checked; 2 errors, 16 warnings.




Rpmlint (installed packages)
----------------------------
Cannot parse rpmlint output:


Requires
--------
gofed (rpmlib, GLIBC filtered):
    /bin/sh
    bash
    bash-completion
    config(gofed)
    coreutils
    fedpkg
    graphviz
    koji
    openssh-clients
    python
    python-PyGithub
    rpm-build
    rpmdevtools
    rpmlint
    tar
    wget



Provides
--------
gofed:
    config(gofed)
    gofed
    gofed(x86-64)



Source checksums
----------------
https://github.com/ingvagabund/gofed/archive/cab0f0b7fc74c7f7eb38b597c30347a87c83c832/gofed-cab0f0b.tar.gz :
  CHECKSUM(SHA256) this package     : c82051d150882895a2733a730a7712e6635c4ffe027e1187187c5a3c343a2fa5
  CHECKSUM(SHA256) upstream package : c82051d150882895a2733a730a7712e6635c4ffe027e1187187c5a3c343a2fa5


Generated by fedora-review 0.5.2 (63c24cb) last change: 2014-07-14
Command line :/usr/bin/fedora-review -rn gofed-0-0.1.gitcab0f0b.fc20.src.rpm
Buildroot used: fedora-21-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG

======
In summary, please fix the %postun and %preun files, as they shouldn't create symlinks/rm without checking
add noreplace to %config and sync the %changelog version with commit.
I'll rerun the review with the new build.

Thanks!

Comment 3 Jan Chaloupka 2015-03-26 19:02:39 UTC
Thanks Ondrej,

I have uploaded updated srpm and spec file:

Spec URL: https://jchaloup.fedorapeople.org/reviews/gofed/gofed.spec

SRPM URL: https://jchaloup.fedorapeople.org/reviews/gofed/gofed-0-0.1.gitcab0f0b.fc20.src.rpm

Koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=9336752

$ rpmlint gofed-0-0.1.gitcab0f0b.fc20.src.rpm gofed-0-0.1.gitcab0f0b.fc20.x86_64.rpm gofed-debuginfo-0-0.1.gitcab0f0b.fc20.x86_64.rpm gofed.spec
gofed.src: W: spelling-error Summary(en_US) devel -> delve, devil, revel
gofed.src: W: spelling-error %description -l en_US automize -> atomize, automatize
gofed.src: W: spelling-error %description -l en_US devel -> delve, devil, revel
gofed.src:4: W: mixed-use-of-spaces-and-tabs (spaces: line 2, tab: line 4)
gofed.x86_64: W: spelling-error Summary(en_US) golang -> Angolan, Golan, Angola
gofed.x86_64: W: spelling-error Summary(en_US) devel -> delve, devil, revel
gofed.x86_64: W: spelling-error %description -l en_US automize -> atomize, automatize
gofed.x86_64: W: spelling-error %description -l en_US golang -> Angolan, Golan, Angola
gofed.x86_64: W: spelling-error %description -l en_US devel -> delve, devil, revel
gofed.x86_64: E: arch-dependent-file-in-usr-share /usr/share/gofed/parseGo
gofed.x86_64: E: statically-linked-binary /usr/share/gofed/parseGo
gofed.x86_64: W: non-etc-or-var-file-marked-as-conffile /usr/share/gofed/config/gofed.conf
gofed.x86_64: W: non-conffile-in-etc /etc/bash_completion.d/gofed
gofed-debuginfo.x86_64: E: debuginfo-without-sources
gofed.spec:4: W: mixed-use-of-spaces-and-tabs (spaces: line 2, tab: line 4)
3 packages and 1 specfiles checked; 3 errors, 12 warnings.

I have completely removed %postun and %preun sections and fixed commit in changelog and added config(noreplace).

Comment 4 Ondrej Oprala 2015-03-26 20:34:31 UTC
[ ]: Changelog in prescribed format.
>>> OK
[ ]: %config files are marked noreplace or the reason is justified.
     Note: No (noreplace) in %config /usr/share/gofed/config/gofed.conf
>>> OK
[ ]: Package does not generate any conflict.
>>> OK

gofed.x86_64: W: unstripped-binary-or-object /usr/share/gofed/parseGo
also fixed :)

fedora-review also ran the Python plugin this time:
Python:
[ ]: Python eggs must not download any dependencies during the build process.
>>> OK
[ ]: A package which is used by another package via an egg interface should
     provide egg info.
>>> OK
[ ]: Package meets the Packaging Guidelines::Python
>>> OK
[x]: Binary eggs must be removed in %prep

Thanks, I don't see any further issue.

APPROVED

Comment 5 Jan Chaloupka 2015-03-26 20:55:29 UTC
New Package SCM Request
=======================
Package Name: gofed
Short Description: Tool for development of golang devel packages
Upstream URL: https://github.com/fedora-cloud/gofed
Owners: jchaloup
Branches: f22 f21 f20 el6
InitialCC: golang-sig

Comment 6 Gwyn Ciesla 2015-03-27 12:34:42 UTC
Git done (by process-git-requests).

Comment 7 Fedora Update System 2015-03-27 13:57:18 UTC
gofed-0-0.1.gitcab0f0b.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gofed-0-0.1.gitcab0f0b.fc20

Comment 8 Fedora Update System 2015-03-27 13:58:07 UTC
gofed-0-0.1.gitcab0f0b.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gofed-0-0.1.gitcab0f0b.fc21

Comment 9 Fedora Update System 2015-03-27 13:58:24 UTC
gofed-0-0.1.gitcab0f0b.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gofed-0-0.1.gitcab0f0b.fc22

Comment 10 Fedora Update System 2015-03-27 13:58:40 UTC
gofed-0-0.1.gitcab0f0b.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/gofed-0-0.1.gitcab0f0b.el6

Comment 11 Fedora Update System 2015-03-28 18:37:57 UTC
gofed-0-0.1.gitcab0f0b.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 12 Fedora Update System 2015-04-02 07:57:05 UTC
gofed-0.0.1-0.1.git62b0051.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gofed-0.0.1-0.1.git62b0051.fc22

Comment 13 Fedora Update System 2015-04-02 10:30:11 UTC
gofed-0.0.1-0.1.git62b0051.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gofed-0.0.1-0.1.git62b0051.fc21

Comment 14 Fedora Update System 2015-04-02 10:33:53 UTC
gofed-0.0.1-0.1.git62b0051.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gofed-0.0.1-0.1.git62b0051.fc20

Comment 15 Ville Skyttä 2015-04-04 08:11:31 UTC
(In reply to Ondrej Oprala from comment #2)
> [ ]: Useful -debuginfo package or justification otherwise.
> >>> OK - No debuginfo for golang stuff

If this is true for an arch specific package, the empty -debuginfo package needs to be explicitly disabled.

Comment 16 Jan Chaloupka 2015-04-06 11:09:55 UTC
Hi Ville,

debug info is no longer empty. The first fedora-review was run on a spec file with no debug info stripping. The second run was on spec file updated for building binaries with support for debugging symbols. Thus debuginfo package is no longer empty.

$ rpm -qpl gofed-debuginfo-0.0.1-0.1.git62b0051.fc23.x86_64.rpm
/usr/lib/debug
/usr/lib/debug/.build-id
/usr/lib/debug/.build-id/7c
/usr/lib/debug/.build-id/7c/11b13a5b64746ad7fdf1dc5fbe8f238381f344
/usr/lib/debug/.build-id/7c/11b13a5b64746ad7fdf1dc5fbe8f238381f344.debug
/usr/lib/debug/usr
/usr/lib/debug/usr/share
/usr/lib/debug/usr/share/gofed
/usr/lib/debug/usr/share/gofed/parseGo.debug

Comment 17 Fedora Update System 2015-05-09 13:59:56 UTC
gofed-0.0.3-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gofed-0.0.3-1.fc22

Comment 18 Fedora Update System 2015-05-09 14:01:18 UTC
gofed-0.0.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gofed-0.0.3-1.fc21

Comment 19 Fedora Update System 2015-05-09 14:01:39 UTC
gofed-0.0.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gofed-0.0.3-1.fc20

Comment 20 Fedora Update System 2015-06-23 13:22:37 UTC
gofed-0.0.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gofed-0.0.5-1.fc22

Comment 21 Fedora Update System 2015-06-23 13:22:59 UTC
gofed-0.0.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gofed-0.0.5-1.fc21

Comment 22 Fedora Update System 2015-07-27 15:30:38 UTC
gofed-0.0.6-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gofed-0.0.6-1.fc22

Comment 23 Fedora Update System 2015-07-27 16:21:33 UTC
gofed-0.0.6-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gofed-0.0.6-1.fc21

Comment 24 Fedora Update System 2015-08-22 02:50:41 UTC
gofed-0.0.8-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update gofed'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13949

Comment 25 Fedora Update System 2015-08-22 04:19:11 UTC
gofed-0.0.8-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update gofed'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13948

Comment 26 Fedora Update System 2015-11-18 12:34:11 UTC
gofed-0.0.10-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ae3431a7c2

Comment 27 Fedora Update System 2015-11-19 14:52:04 UTC
gofed-0.0.10-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gofed'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ae3431a7c2

Comment 28 Fedora Update System 2015-11-19 15:26:44 UTC
gofed-0.0.10-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gofed'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-bd2922d501

Comment 29 Fedora Update System 2015-11-19 16:55:19 UTC
gofed-0.0.10-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gofed'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-bd2922d501

Comment 30 Fedora Update System 2016-01-26 03:21:09 UTC
gofed-0.0.10-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2016-01-26 18:28:37 UTC
gofed-0.0.10-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.